Deselect/commit row being edited in Kinetic grid

Hi all,

I am successfully using an editable grid to send changes to an Epicor Function. All is well, but how can the user “confirm” row or cell changes other than selecting another row? Currently I’m submitting the updated dataview to a function, then refreshing the dataview. Unless the user has clicked on a non-editable column in another row, the last row they edited remains open. Then when the dataview refreshes, the currently selected row blanks out its values. If the user then selects another row, the values return.

Is there a programmatic way to “commit” the grid, deselecting any row currently being updated? I’ve tried the dataview-commit event with no effect. Any hidden properties I can set on a grid to force this to happen?

On a normal text box you can use an event handler. For a grid i’m not sure if there is anything you are able to do.

I noticed same behaviour on my end. I was going to create new thread but this one is describing my issue very well. There is already one answer here, but not answering (sorry) at all and referring to classic interface and not to Kinetic.

The question is how to exit edit mode of currently edited row in the grid.
My event is triggered by DataTable ColumnChanged.

@hmwillett @klincecum I think it might be interesting for you as well… or maybe you have already some solution?

I can’t really replicate what you’re talking about to test it, but you could try to use the grid-schema-invalidate widget to see if that works.

If widget configuration is ok then “grid-schema-invalidate” doesn’t work.

If I will select anything in column number 3 (drop down) then my event is triggered, it call function which is saving data, then I am refreshing dataview. But my row looks like at the image below:

If I will exit edit mode by clicking in other place then my “data” is visible again.

Edit: In other thread someone mentioned about “grid-refresh” widget. But I am on 11.2.200.x and “grid-refresh” is not available.

@Jordie wrote: “We have version 11.2.300.1 installed right now and I can use a tile ‘grid-refresh’ now to update the grid results :partying_face:

Oh–maybe that’s why I cannot replicate it. I’m testing in 2023.1 using grid-refresh. :rofl:

*Edit - Lemme poke this in 2021. If I can find something in that version, then it should work in yours in 2022.

Interesting yes. Whether I can be helpful is another question altogether. I’m still very
much a beginner with the new interface. Hopefully @hmwillett has luck poking it.

Thanks in advance. Fingers crossed :).

I hate 2021.1…

I tried this with Order Entry, Quote Entry, and PO Entry and they’re all doing the same thing.
Menu path? Works fine–like an entry form.
Preview from App Studio? All of a sudden, it’s a tracker. Sooooooo, I can’t test anything.

I’m also very tired, so if I’m having a “derp” moment, someone please tell me. :sweat_smile: