DMT Bill of Operations giving error "Column CreatedOn does not belong to table PartRev"

Im trying to update about 1500 operations so im starting with a simple upload of 7. Im using Bill of Operations in DMT and ill share a screenshot of my fields below. i noticed that i have a single operation already on my part so i planned on removing it and then uploading my changes. Whenever i run the single line removal i get the error below. For the hell of it, i tried to upload my operation changes (different sequencing so it would just add on at the bottom) but that gave me the same error. I closed out of DMT, restarted the task manager, and even made a new csv file with the test info but i still get it. I have never gotten this error in the past so im either doing something terribly wrong or something is acting up on my server side.


Have you upgraded to a different version of Epicor since the last time you processed a BOO upload? If so, did you download the version of DMT that corresponds to the new version of Epicor?

If nothing has changed, then I’m not certain as to what to tell you. If you have upgraded, AND you have the proper version of the DMT tool, then contact Epicor Support. It’s difficult for me to help you as I’m on the SaaS cloud, Kinetic version 2022.2.11 - and they actually broke DMT for processing ARCombined in this version, which we had to have Epicor provide us a fixed DMT tool.

A lot keeps changing regarding the BOO & BOM templates as they’ve been continuously updating new functionality that they’ve added over the past several years. (For a lot of different modules actually). Sometimes DMT stops playing nicely in different versions. With almost each upgrade, we have to reevaluate some of our templates as they stop working.

1 Like

yea not surprised they keep breaking it with their updates. We went from 10.0 to 10.1 about 6-7 years ago and i believe our dmt is the proper version since the last time ive done a BOO update it worked fine on this DMT version and 10.1… I contacted epicor support so if they actually help out ill post my update but ill leave this open until something changes.

I’m assuming you deleted your company value from your image (for privacy reasons)… but does “company” need to be capitalized? I’m assuming DMT is case sensitive.

Not sure if this would cause your above issue, just noticed you had it lowercase.