DMT - Deleteing Materials


Good afternoon,
I am using the DMT to delete all the materials for a part/rev. I intend to reimport the materials with the DMT after I am done. I worked this out using a couple of sample parts, and the delete worked well. However, I just ran it for a larger list of parts, and I am getting this error I don’t know what to do with.

2022-07-27T12:50:41	 MYPARTNUMBER MYREV MYMTLPARTNUM Column 'ECOMtlRestriction#RestrictionTypeID' does not belong to table .
Column 'ECOMtlRestriction#RestrictionTypeID' does not belong to table .

I am confused because I didn’t try to import/delete anything in that restriction table, and I don’t see it as a required field. I also don’t see any place that we used the restrictions, so we should be able to ignore it. What am I missing here?

Hey Nate,
What is it exactly you are trying to achieve? Have you looked at the Mass Part Replace/Delete program in Kinetic? (the name is a bit misleading as it does refer to component parts).

Are you able to show a snippet of the file you are trying to upload?

Another thing, even though DMT has thrown an error, have you double checked in Kinetic to see if the data has changed as desired?


When doing mass part updates, my SOP was to delete the whole ECO group via te UI and re-import via DMT. I didn’t bother with partial resets.

Our end goal is to update all of the operations for our part/revs. We are only doing this at first for part/revs that have an open job. We have to replace our operations for every part/rev, and part of that is deleting the operation. To delete the operations I have to delete the materials first. My process is to run the DMT to delete the materials (from Bill of Materials), then run it to delete the operations (from Bill of Operations), then I reload the operations with DMT and reload the materials with DMT. I haven’t been looking into the mass part/replace program.

When DMT throws the error, it leaves the part rev checked out in the Engineering workbench. I just mass check in and approve all the parts in my ECO group, and the materials seem to have been deleted correctly. So the delete DMT does work, it is just giving an error I can’t figure out, and leaving the parts checked out, as it should.

I can’t really post a snip here as the file is all part and material numbers that I shouldn’t share. But I have this file format:
Company PartNum RevisionNum MtlSeq MtlPartNum Plant ECOGroupID

As I was reviewing my data I noticed a few duplicates in there. My BAQ must be exporting additional details that I didn’t filter out. I will make sure that my BAQ export is only showing distinct records for my next test.

I think this was the ticket! After setting my top level query to return distinct rows, I am no longer getting that error. WOO!!

Thought it would be a phantom error…

In order to re-import those materials back once, the Operation change has happened, you might need more columns than that(QtyPer, etc). If you want to get to the bottom of the error message then I suggest you run the deleted file again but with the same columns you would use in the next import file.

What columns you’ll need will depend on your data, if you search here you’ll find posts of others trying to do similar things. The last time I did a BOM upload I needed;
Company, PartNum,RevisionNum, MtlPartNum, MtlSeq, QtyPer, UOMCode, MfgComment, EstScrap, EstScrapType, PullAsAsm, ViewAsAsm,PlanAsAsm, RFQNeeded, RFQVendQuotes, Plant, ECOGroupID
and I never received the error you have (version 2021.1 & 2021.2).

Another thought I had while typing this out, appease DMT and include the column but leave the fields null?


1 Like

Thanks Joe! I have successfully imported the materials. Thankfully that part didn’t give me any errors. Yes, the import file has a lot more fields. and I had to find out by trial and error which ones need to be removed (because they are calculated). For example, I had an issue with RunQty. It is a calculated field based on QtyPer, but I was trying to import it. This caused an error. Rather than reimport a calculated field, I just deleted the RunQty column, and it was recalculated correctly for me!

You all said I would love the DMT once I finally got it setup. I am so thankful that we have it now! There are some little gotchyas. But, there is no way I could process this volume of data with trial and error using UBAQs! I have to say, for once, this Epicor tool just works! :slight_smile:

1 Like

I am back to this question again. I am just trying to delete the materials. I have a very minimal field set for deleting. When I ran this a few days ago I got the errors to stop by ensuring I didn’t have duplicates in my file. Now I a m sure I don’t have duplicates, but I am still getting the error. I even went back to my old file from my last post and tried using that to delete materials, and I get the same error. I will keep trying to get this to work. If you have any other ideas, I would be happy to try them!

Interestingly the error only seemed to happen for the first 20 or so materials. I kept stopping it before it got beyond this point. After I let it run, the errors stopped and it seems to be processing them ok. I wish I knew what was going on here. That error message doesn’t tell me anything.

Nate, I’m a positive noob on DMT, we’re getting ready to go-live with our first company in Epicor, but I’ve been working on DMT for a bit and some of our errors like this have been tracked down by checking the part in the UI. We had a part that had been checked out so it was giving errors on the Bill of Matl import IIRC.

1 Like

Hey Nate,

this is a dumb question but have you tried adding" ECOMtlRestriction#RestrictionTypeID" as a column in your upload file?

I had the same issue while trying to delete bill of materials and I was trying to get rid of duplicates like you suggested and it didn’t really change anything but when I added the “ECOMtlRestriction#RestrictionTypeID” column it ran and deleted the materials.

For your reference:


I didn’t try that. I think the template was asking for that field, but I didn’t have anything to put there. Where did you get the values you used for that field?

I made it up just like a transaction reference field.

Here is the BAQ I made for exporting the data:
BOM_DMT.baq (19.5 KB)

You might want to put a filter on PartNum on the ERP.Part table since this will load all materials for every assembly.