DMT Error - External Table is not in the expected format

I am trying to update a few operations and I can’t even pull in my spreadsheet. I have recreated it 3 times and no luck.

Any thoughts on this error?

I fixed my own issue. I had a column with wrong name. I am surprised it gave me that error and not column not valid.

I wanted to add to this thread and report that I am experiencing this same error message on one of our Excel spreadsheets with Macros. It is an .xlsm spreadsheet with 3 tabs and every time I try to load it into the DMT it gives this error:


I’ve tried loading it into the DMT on our Epicor server itself and on my PC and on a test server but they all give the same error above. Yet the craziest thing is my co-worker, who created the spreadsheet, can load it into the DMT on his PC just fine without getting this error. I’ve seen it with my own eyes! :eyes: Go figure!? :woman_shrugging:

When I delete the “ReportData” tab as shown in the image above but leave the “EpicorData” and “Setup” tab the .xlsm spreadsheet will load for me without the error. I wonder if DMT is trying to open the Spreadsheet up using the “ReportData” tab? But every time I open the Spreadsheet in Excel it defaults to the “EpicorData” tab. And why wouldn’t it give me a columns are invalid error instead?

And if I save the entire (all 3 tabs) .xlsm spreadsheet as an .xlsx then I can load it into the DMT without any errors.

Just wondering if anyone has seen this before and might know of something that we can do to fix this?

In the meantime, my co-worker is just going to have the macro in the .xlsm spreadsheet save the “EpicorData” tab data to an .xlsx and I’ll pick it up with the DMT from there.

Thank you for any thoughts or ideas you might have on this mystery.
-Heather :ghost: :mag_right: :female_detective:

I’ve run into problems where DMT won’t read an .xlsx spreadsheet that has any colors or formatting in it. DMT would completely freeze and need to be killed from the task manager. But it would read the same file just fine after I converted it to .xls and/or removed all formatting. My habit now is to use only .xlsx files with a single sheet and no formatting.


I have always has issues with spreadsheets that have more than one tab and only use one tab.

1 Like