DMT error You do not have permissions, but i do

I copied Production database over to Test, Production for some reason is stuck rebuilding, but thats OK for now, but when i try to DMT over customers, I get a

“Table; Customer Msg: You do not have permissions to this record.”

I have tried to DMT using Manager and my own account, but they don’t work, but i have used both before to DMT, not sure why it is different now. We also both have DMT enabled on our accounts and DMT as a license.


Do you have territory security turned on? It could be both users would need to have access to all territories. Try something with the part table and see if DMT works there.

1 Like

Territory Security… where I would I work with that, I don’t remember ever setting that?

also, Suppliers worked,… so it must be Territory Security… it’s the little things, now I just need to know where to change that.

so funny thing, USA was not listed in the Territories, but it would not let me allow it, saying was a duplicate… though there was nothing there, so I created U.S.A, I opened up work Force (which system manager was never a part of) and assigned it to my user. i loaded the updated csv which had my customers with U.S.A. instead of USA and I got territory errors. Then I loaded the previous CSV with USA, and it worked. what doesn’t make sense is, manager used to do it just fine (like 2 days ago) and i did too, why is it so different?

You can gain access to all territories through workforce maintenance:

For the company it’s set up on the configuration:

1 Like

I’m not sure. I know once it’s turned on, it can wreak havoc until the users who are defined in the workforce that don’t have the View All Territories checkbox enabled.

Was territory security turned on before this week? Did somebody run an update or change the workforce? Do you have an older snapshot that you can look at to see?