Drop down list in combo box is populated with empty values

Hi guys, please advise what I am doing wrong?

I added a compo box, which is populated from the Erp.BO.ReasonSvc service’s GetList method:


but drop down contains only empty values:


however, when I click on something, I see that value is being picked:

I assume it has something to do with the response model:

and I tried to use Description as a value for Retrieve columns:

then I tried returnObj.ReasonList as a value for Retrieve columns, but it didn’t help as well

I have a strong suspicion that I can’t use something other than predefined combos/BAQ/UD GetList service here, but I can’t find the reason why, as for me UD service is quite the same, except the response model

Is there a reason you’re not using the Reason.ReasonCombo prebuilt one?

3 Likes

it’s funny, but I did check, and the values it returned, weren’t A type.
However, with the filter it seems it returns needed values:



and drop down seems to be working as well:

so, I have a solution, thank you

but I am curious, what’s missing in my implementation?

2 Likes

I made a UD combo box not two months ago … does it matter what the value of the ComboId field is? I have never put anything there

Could you try it without any value there?

Initially it had been empty, I added value there as an attempt to fix the issue

1 Like

I just threw a combo box with your same configuration on a random screen and it seems to work fine:
image
With the same response model:
image

Configuration:


image

You might just have to delete and re-create your combo…
Then again, I’m working on 2023.2 - so we might get different results if you’re on a different version :man_shrugging:

1 Like

that’s interesting, our version is 2023.2.11, so, I suppose results should be the same

thanks, will try tomorrow

I had that problem yesterday working with Combo in 2023.2.11 so agree, recreating the item may work.

1 Like