E10 Error Message: RE account is wrong

I am launching a new company and when I post a GL journal I get the error message RE account is wrong. Account is inactive. But when I look at the RE account it is active. Any ideas

Could you give us more information, usually the best way is to Paste the Error Stack (In the Error Window MsgBox, you click Details) and then Paste the entire text as you see it.

It helps us see the Stack and the Methods that Epicor called that lead up to the Error.

In the Review Journal all there is have is the one line stating RE account is wrong - Account Inactive. I went to the System Monitor and pulled error log
No Records Selected
at Ice.Services.Lib.RunTaskSvc.InnerRunTask(Int64 ipTaskNum, Boolean suppressTransaction) in c:_Releases\ICE\3.1.400.10\source\Server\Services\Lib\RunTask\RunTask.cs:line 477
at Ice.Services.Lib.RunTaskSvcFacade.RunTask(Int64 ipTaskNum) in c:_Releases\ICE\3.1.400.10\source\Server\Services\Lib\RunTask\RunTaskSvcFacade.cs:line 97
at SyncInvokeRunTask(Object , Object[] , Object[] )
at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)
at Epicor.Hosting.OperationBoundInvoker.InnerInvoke(Object instance, Func2 func) in c:\_Releases\ICE\3.1.400.10\source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 59 at Epicor.Hosting.OperationBoundInvoker.Invoke(Object instance, Func2 func) in c:_Releases\ICE\3.1.400.10\source\Framework\Epicor.System\Hosting\OperationBoundInvoker.cs:line 28
at Epicor.Hosting.Wcf.EpiOperationInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) in c:_Releases\ICE\3.1.400.10\source\Framework\Epicor.System\Hosting\Wcf\EpiOperationInvoker.cs:line 23
at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)
at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)
at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)
at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)
at System.ServiceModel.Dispatcher.ChannelHandler.DispatchAndReleasePump(RequestContext request, Boolean cleanThread, OperationContext currentOperationContext)
at System.ServiceModel.Dispatcher.ChannelHandler.HandleRequest(RequestContext request, OperationContext currentOperationContext)
at System.ServiceModel.Dispatcher.ChannelHandler.AsyncMessagePump(IAsyncResult result)
at System.ServiceModel.Dispatcher.ChannelHandler.OnAsyncReceiveComplete(IAsyncResult result)
at System.Runtime.Fx.AsyncThunk.UnhandledExceptionFrame(IAsyncResult result)
at System.Runtime.AsyncResult.Complete(Boolean completedSynchronously)
at System.ServiceModel.Channels.SecurityChannelListener1.ReceiveItemAndVerifySecurityAsyncResult2.InnerTryReceiveCompletedCallback(IAsyncResult result)
at System.Runtime.Fx.AsyncThunk.UnhandledExceptionFrame(IAsyncResult result)
at System.Runtime.AsyncResult.Complete(Boolean completedSynchronously)
at System.ServiceModel.Channels.TransportDuplexSessionChannel.TryReceiveAsyncResult.OnReceive(IAsyncResult result)
at System.Runtime.Fx.AsyncThunk.UnhandledExceptionFrame(IAsyncResult result)
at System.Runtime.AsyncResult.Complete(Boolean completedSynchronously)
at System.ServiceModel.Channels.SynchronizedMessageSource.ReceiveAsyncResult.OnReceiveComplete(Object state)
at System.ServiceModel.Channels.SessionConnectionReader.OnAsyncReadComplete(Object state)
at System.Runtime.Fx.AsyncThunk.UnhandledExceptionFrame(IAsyncResult result)
at System.Net.LazyAsyncResult.Complete(IntPtr userToken)
at System.Net.LazyAsyncResult.ProtectedInvokeCallback(Object result, IntPtr userToken)
at System.Net.Security.NegotiateStream.ProcessFrameBody(Int32 readBytes, Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security.NegotiateStream.ReadCallback(AsyncProtocolRequest asyncRequest)
at System.Net.AsyncProtocolRequest.CompleteRequest(Int32 result)
at System.Net.FixedSizeReader.CheckCompletionBeforeNextRead(Int32 bytes)
at System.Net.FixedSizeReader.ReadCallback(IAsyncResult transportResult)
at System.Runtime.AsyncResult.Complete(Boolean completedSynchronously)
at System.ServiceModel.Channels.ConnectionStream.IOAsyncResult.OnAsyncIOComplete(Object state)
at System.Net.Sockets.SocketAsyncEventArgs.OnCompleted(SocketAsyncEventArgs e)
at System.Net.Sockets.SocketAsyncEventArgs.FinishOperationSuccess(SocketError socketError, Int32 bytesTransferred, SocketFlags flags)
at System.Net.Sockets.SocketAsyncEventArgs.CompletionPortCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* nativeOverlapped)
at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP)

I am not a finance modules expert, but based on the Error and some research, this may help point you in the right direction.

So the “RE” Account is short for Retained Earnings Account. Few things that could be wrong:

  • The Segment Order is not matching
  • Retained Earnings account is wrong for opening balance period
  • Account is inactive for next year first period
  • Your Retained Earnings Account may actually be Inactive

Could it be that you are trying to post something from or to previous year where the year has already been closed? Not sure if this relates:

We’ve always re-opened the prior year, made the journal entries for the tax expense and liability, closed the period and ran “Transfer Opening Balances to Next Year”. When you do that, you have to select prior year to current year. The opening retained earnings are automatically updated with the opening balance transfer process.

Many thanks - you have at least given me a direction in which to start looking!

1 Like

Make sure you also check dates for example in the General Ledger Account Maintenance
2019-02-10_1330

I guess its an Account you set on your GL Book:

So possibly go to your GL Book Maintenance and see what the RE Account is and then Open That with (via right click open with) General Ledger Account Maintenance and Verify its Activate and that its From and To dates are not expired.

2019-02-10_1339

will do - I confirmed we were able to post Fri during testing. I printed trial balance. I confirmed fiscal year and period were not closed. I confirmed RE account was active.
Next I will go check the book maintenance. Thanks!

Good! Make sure its not Blank - if it never told you the Account Number in the Error it may not have one populated, perhaps blanked. Hope the info helps, and you find the culprit.

Two rules in double-entry accounting:

  • Debits must equal credits for each transaction
  • Assets = Liabilities + Retained Earnings
    or put another way:

Assets - Liabilities = Retain Earnings

Closing the period moves the gain or loss to the Retain Earnings account. It’s the scorecard for how the company is doing since it’s inception.

1 Like

That screams that there were no transactions to post.

If the incredibly unlikely circumstance existed where assets = liabilities, the RE would be zero. And E10 doesn’t create transactions for $0 entries.

I just figured she pasted one of multiple Errors, but if that is indeed the only one then agreed, it simply didn’t find anything to post @skcrowder

1 Like

Thanks to everyone that advised me on how to resolve the error message RE account is wrong! When I looked in Book Maintenance, Retained Earning account, the correct account appeared. However, Epicor kept telling me that the RE account was inactive.
I finally deleted the entry and reentered the RE account manually. The initial load was done via a DMT. After manually adding the RE account, I returned the journal to Journal Entry and attempted to post a second time. This time it worked! When I opened the DMT I noticed the row after the RE account was highlighted. I think Excel stored a hidden character at the end of the RE description, which was loaded when I processed the DMT. I cleared the highlighted area, resave, repeat the DMT load, added another journal and it worked for the other 13 companies I was creating!

3 Likes