ECOGroupID shows ECODescription in dashboard Tracker

Has anyone ever run across this situation? I am trying to use a Tracker in a dashboard to select a GroupID from a BAQ (based on ECOGroup) and when I select the combo box for the ECOGroupID (We use this as an ECO number) I only see descriptions for the ECO , not the ECOGroupID. I even tried using a 1 field BAQ with only the GroupID from the ECOGroup table and I still get the description in the Tracker and the GroupID in the Grid view … I’m stumped…

Yes, this happens a lot in Dashboard Tracker Views.
Where Epicor defaults to being “helpful”… and the combos have limited properties for you to modify

2 workarounds I’m aware of - that go soemthing like this…

Option 1.) Add a Tracker BUT DON’T add a filter for GroupID thru Tracker Properties - instead customize that Tracker (you may need to include at least one fieldin the tracker before you can customize, e.g Company)
a.) and add a text bo
b.) bind it to the groupI field
c.) set dashboard prompt = true
— e.g. “equals”, “starts with”, “greater than”, etc…
— then you can typeyour search pharase in the text box & it will execute against the GroupID

Option 2.) Add a tracker view (this time include the GroupID)
a.) Deploy your dashbaord to the menu
b.) Turn on Dev mode in E10
c.) Launch your Dashboard
d.) initiate customizaton (the dashboard “Assembly” - .dll)
e.) add a new combo to your tracker view - where you can modify whcih field displays
f.) hide the other combo that was shoing the GroupdDescr
g.) save the customization
h.) then go to menu maintenacne - specify your new customization

Thank you Bruce,

Using option 1. Works like a charm.