Enterprise Search

Anyone seeing issues with Enterprise Search in 10.2.600? The index builds complete and ES will search a couple times then just stop searching.


Enterprise Search will never works in Active Home Page on 10.2.600.X, In Classic works fine.
It’s supposed to be fix it in 10.2.700.X :pensive:
This is that Epicor Support told me:

PRB0226197 - Customers are reporting issues when doing a new install of EES 10.2.600.x where the search results are wrong when used in KHP interface. Support replicated in 10.2.600.8. In the steps to replicate, where support tested in our environment with 2 examples. One search term ‘1032KNUT’ will return 0 results back via KHP (results return back correctly via Modern UI). Another search term ‘ADDISON’ will return back incomplete results back via KHP.


Well… that sucks but good to know. Thanks!

Just wondering if you were able to get yours to work in the classic interface? I’m having issues whether classic, normal or kinetic… none return results.

Yes, EES works fine in my test environment in 10.2.600.19 (in Cassic and Modern Shell):

Verify that Search URL port (8098 commonly) is open on Windows Firewall, and the Epicor Search Index Service is running under domain account:

It works fine in classic for us. And Epicor support indicated it should. Sounds like a potential config issue if it doesn’t work in either shell.

I opened an Epicor ticket to try and push for a fix in 600. They said that’s not going to happen and that it’s not consistently broke for everyone. So they can’t easily patch 600. Must be a weird bug that only pops up in certain cases :man_shrugging:t2: Epicor support didn’t elaborate just said it’s fixed in 700 update.

Turns out that my issue with the Classic interface Enterprise Search was due to not enabling session impersonation on the search user. :roll_eyes:
Still unable to use the search on kinetic. I wonder if the inconsistency is due to differing authentication methods.

That could be in some environments. We are all SSO so not the issue for us.

This happened to us when we were on 10.2.600.7 all the way up to 10.2.700.4 (we are public cloud SaaS so we get each and every update). Back on 10.2.600.7, the cloud team did something to fix the issues (but they never told me what they did) and then had to recycle the app pools. Then Enterprise search worked on the Kinetic Home Page.

Here is a case that might help you out:

@BKen - that knowledge page seems to insinuate that the issue will be resolved by rebuilding the search index. I’ve tried this many times and has no effect. Also, our instance is a fresh install, not an upgrade so the issue may be different.
I think this case (10.2.600 kinetic) is probably related to the authentication, not the index itself.

Hi Everyone,

I had a similar problem, only Classic and Shell worked and Kinetic Search simply didn’t find anything (empty result). I solved it by changing the binding to use HTTPS instead of NET.TCP.

Enterprise Search does work for the 3 clients in 10.2.600 and 10.2.700 as long as you setup the SearchIndex to use HTTPS binding instead of the default NET.TCP. The reason is that the Enterprise Search’s search screen on the Kinetic (web) client connects to Epicor using HTTPS binding only, whereas Classic and Shell, either use both, or net.tcp only.

So, when you setup the SearchIndex for your environment, after deploying the extension, click on the “previous” button until you arrive to “server connection” and change Endpoint and binding params.

Kinetic search:


Hi Carlos,

your solution looks great!
Have tried this at a Test system in combination with both SSO and HttpsBinaryUsernameChannel in endpoint binding active.
Changed the Search index server connection to https://.etc., validate connection: successfully.
Changed url in Company maintenance and tried search: no result.
In eventlog message: “You can only log on via single sign-on” with the used useraccount.
Double checked this user and it doesn’t have the “SingleSignon only” part set.

Any suggestion is welcome!
Kind regards, Paul

Hi there sorry as I still fresh for this, but i cant find any search panel, is there some where i has not enable or?