Epicor 9 AR Invoice Post Issue

I’m having trouble posting a few groups of AR invoices and am getting the following errors. It’s been years since I’ve had AR invoices get stuck in the posting process and had to use Conversion 10250 to unlock them. I tried that on these groups and I continue to get the below error messages in my posting log on AR Invoice Entry. I’ve also checked and tried the following:

  1. Transferred the invoice to another group.
  2. Conversion program 10250
  3. no changes made to posting rules in years
  4. Turned the PE Log on and it validates

All invoices have been printed and sent to the customers, so deletion isn’t an option. The only thing they all have in common is that they were generated from Project billing for Fixed Fee projects, but this process has been in place for years with no issue and my users have been able to post other AR invoice groups without issue. Any thoughts?


@balmon It looks like the posting rule for fixed fee might have gotten messed up. If your AR Invoice is not a customized posting rule I would try in a test instance importing a default AR invoice posting rule and then try posting this group.


Thanks for the input. I think we have a minor customization of the posting rules, there but nothing that I can’t re-work. I tried loading the standard posting rules, and ran into the same issue. I tried manually reviewing the entries in the review Journal, and they validate in there, but when I go to post the Review Journal, it gives another error and says to check the app servers. When I look in there, no logging is present. My next step is to up the logging level on the app server to Verbose (it’s error only right now) and see if that provides more clues. I’ve never had an invoice get this stuck.

This is getting more interesting. When I trace the transaction using the PE Log Viewer, it appears the posting rules aren’t finding the current Invoice/Company.

Couple of additional notes:

  1. Other invoices have continued to post fine
  2. This only applies to invoices of Type Project Fixed Fee billing that were created using the Invoice Project Billing Generation feature.

here’s a screen shot of the PE log for the “Edit List” posting mode:

and here’s a picture of the PE log for the “Post” Posting mode, it’s like the post rules don’t find the “Details” section which contains the InvcHead info and that ends up causing the process to stop.

Any thoughts on what to check from here would be great.

@balmon I would look at the invoice head to see if it was missing the company and contact support for a data fix.