Epicor Data Discovery


So I was tasked with creating some charts on the Active Homepage. It seems like im stuck with only a specific list of charts to choose from. Am I able to add any additional charts of my own? Im on Epicor Does anyone have any documentation on how to do this? We will not be upgrading to the new Active homepage anytime soon.


A new chart style (like bar, line, scatter, pie, pareto) or new chart source data? If it’s new data, you can use your own BAQ.

Chart style. Id like to use the functionality that is there with the premade charts. the chart view on the active homepage and the gridview when you click on the chart and start drilling down.

What chart style is missing? The EDD workshop at Insights used 10.2.300, and seemed to have a huge selection.

None are missing, id just like to use them on my own BAQ’s on the active homepage

Go for it. Nothing is preventing that.

FYI, your post is a bit confusing. Maybe your question can be re-worded. I read the first post as “We need new active homepage charts but we won’t upgrade to active homepage”, then the second post as “We need a new chart style, not chart source data” and the third as as “We need new chart source data, not chart style”…

1 Like

I apologize, Ill try again.

We have BAQ’s that we would like to be put on the active homepage, but we want them to be seen as charts. I can place my BAQ’s on the active homepage as a grid no problem, but cannot seem to make them into charts. When i select the “Discovery Chart View”, i do not get the option of using my BAQ’s. How can I add my own personal BAQ’s as charts to the active homepage?

We have the same issue, only the BAQ’s provided by Epicor show bet we were told we could use any of our own BAQ’s.

@askulte - I have not done it yet, but I thought you needed to create your objects via EDD first, then you could add them to the Active Home Page… the default list of objects @Vesserik and @rnewell are seeing in Active Home Page is simply the default objects in EDD… Am I correct?

1 Like

In some versions of EDD you need to get a free license from your CAM and then assign them to your users. Have you done anything with licensing/assigning?

1 Like

@MikeGross is right on. I was able to build several EDD Views but I had to first create a new data source and some mess with the right user account that has access. I had to hit up Epicor Support and they were able to get it working with me. But then a few months later all the standard views stopped populating data and I’m now on another support call trying to get that resolved.

EDD UX and terminology is still a bit wonky but it can be done, and I don’t think any special license is needed.

1 Like

I don’t have EDD setup anywhere right now to test but at one point i had to use “zHOMEPAGE” at the start of the BAQ ID for it to show up in the data sources…

1 Like

If you are only seeing the zHomepage BAQ’s - you are most likely still using a pre 10.2 Epicor license. Ask support for a new 10.2.x license with EDD Basic included. You can then load this license against EDD and license users within the EDD Admin page. You will then see all your custom BAQ’s.

One thing to note, pre 10.2.300, Epicor limited the list of BAQ’s to 1000. Post 10.2.300 this was increased to 10K.

This will be fixed in, but if you are on - you can get a hotfix - ERPS-113845.


We have the free license but don’t think we have assigned it to users yet. Will try that today. Thanks Everyone.

Assigning the user to the license in the admin console did the trick. I now see all my BAQ’s.


How do you assign the user to the license in the admin console?

It took me a while to figure this out. Everything is actually done inside of EDD, not in the Epicor Admin Console (except to actually turn on and deploy EDD).

  1. Go to the Settings inside EDD
  2. Click on “Licenses”
  3. Click on “Add License”, then upload your license file
  4. Once added, click on the “Edit” action for your upload license
  5. Search for a user that you want to be able to use EDD, then make sure that the “Is Licensed” box is checked.

Has anybody noticed that some BAQ don’t show up on the list?