Epicor HCM - Candidate Connect Issue

When opening the HCM Candidate Connect in my Test Environment, this is showing the page with the following Text:

Use this page to enroll yourself in Self-Service. Enter the appropriate information in the fields below and when finished click Register Me.

You are logged in as: NT AUTHORITY\IUSR (Important! Do not continue if this is not your correct Windows login!) :

In Production, this is working as normal.

Please suggest what to check ?

You didn’t mention if this message comes up after you try and log in, or before. I’ve not seen that particular page come up for us, but …
Is Test a copy of Production? If so, there is a USysInstallation table that might need a small edit.
Are you trying a URL that is pointed to the right IIS Server and virtual directory?
Is the IIS server set to redirect that URL to the correct portal?
You cannot used deferred auth or SSO with Candidate portal that I know of.

There is so much to ask because your setups can be different between Prod and Test. You have to check that the Portal and associated config files are pointed the to the correct DB and agree with the IIS settings.

This message appears when I open the CSS URL. Yes, there was a correction required in usysinstallation where Machine name was wrong.
I have verified the IIS Server and corrected few areas where server name was wrong.
However, the issue remains same.

I am not good at HCM CSS Configs. since Production remains on DMZ and the old Test Installation is no more available since we changed the Host VM.

Please let me know more on the following configurations:
1- iVantageInstallationConfiguration
2- Web.config and iVantage.config

Also, what should be the Authentication Setting of HCMCss, Currently, Anonymous is Enabled only.


Yasir - I think your best bet at this point is to contact support. Every time I’ve had a serious issue, the solution has been to remove the portal (clean up the directories) and reinstall.

I can tell you that the first config file is simply the installation tool’s data and the other two are what make it work properly - but the settings are all based on your environment. And I’m concerned that you say your Prod server is in the DMZ. This is one of those statements that makes every IT Security person cringe deeply.

I have both anonymous and Forms enabled.

This is really just the database connection string. I do know that you also have a ‘customer id’ in there and that must be correct as well. I think you need to get that from Epicor.

That doesn’t need to be edited manually as far as I know. All the settings are handled via the IIS Admin tool or from the portal installation tool

Thanks Mike, I have raised a case with Epicor Support. this seems more work to do.

Good plan at this point. Don’t forget to come back and post the solution (and mark it) so others can see what the resolution was.