Epicor\Kinetic Performance Issues

The quote I opened was only a couple lines, but our BOMs can be pretty complex and large. Not uncommon to see a BOM with 50+ subassemblies. I’m not familiar with Fiddler, I have played with wireshark plenty of times though and very familiar with networking concepts.

Went to run P&D tool, haven’t ran it since we upgraded to Kinetic, realized this after checking some old emails. Made myself a liar, apologies. Had to install the new P&D tool and update the settings. Now I’m getting a “Object reference not set to an instance of an object.” error when trying to run the network and config checks. I’m working on getting that sorted out and will post the results when I can. It’s always something lol.

1 Like

Okay, got P&D working, attached the results, which shows some fails now, and here’s the network test.

P&D Results.xlsx (1.3 MB)

That’s not bad I suspect your quote dataset is huge can you use wireshark
To see the size of the quote payload?

1 Like

I’ll see if I can get that done and post back. Appreciate the help!

1 Like

For the record, in my experience GetByID taking around 1-2 seconds is normal for quotes… There’s just a lot of tables in that dataset…

1 Like

@CasterConcepts is it every quote that is that slow or just some? If just some look at the customer record for those ones and see how many contacts/ship-to they have


We have this issue on customer shipment entry and I swear you may have just pointed me in the right direction with ship tos.

Back at it today, after looking at Fiddler I decided to give it a go. Looks cleaner and I like how it’s built for HTTP specifically.

Here’s just opening Quote Entry. Not sure what a “good” baseline is for Quote Entry.

Here is opening a record, using the search button:

And this is changing the expected quantity value:

Where do I go from here? Start drilling into things that have a large body?

1 Like

That actually all looks pretty good for a typical quote. Is the issue isolated to quotes? Specific quotes or all quotes certain customers or all customers?

Can you establish / record a baseline for several Customers and Different Parts

Quote Customer 1 Part 1 (Complex BOM)
Quote Customer 1 Part 2 (Simple BOM)
Quote Customer 2 Part 2 (Simple BOM)
Quote Customer 2 Part 1 (Complex BOM)

Make sure you are running Epicor Client “Base” (no customization)

Is your Server / Client all “local” (Same building / network LAN)?


Also, burning question that we never think to ask: are you on Wifi?

@josecgomez, I’ll start running through some various tests.

@HLalumiere, everything is wired for the most part. Specially workstations. All access switches are on a 10GB backbone, direct connect back to the core switch.

For context, I recently upgraded our entire network, every single network appliance was replaced. We are multi-company, we own several other businesses within maybe a 15-mile radius. We have dark fibers running to the other buildings. Our networks are separated by VLANs, servers in one, workstations in another, VOIP phones in another, etc.

We have too many devices to put everything into a single subnet. If it was firewall related, I think we’d have a bigger issue that was more consistent. I did a lot of testing while I was building out the new network lol…

The issues we’re facing are not just one form, job tracker\entry also seem very slow to open, taking 10 seconds or more. Retrieving data doesn’t seem too bad, even for a complex BOM. I focused on Quote Entry because that’s where most of my complaints come from and the easiest for me to replicate. I think if I could fix performance issues with Quote Entry, I’d be better equipped to tackle the rest, or maybe the same issue fixes them all. Maybe Epicor is just Epicor and my team expects miracles… lol.

Have you tried turning on memory caching for the slow forms?

Yes, that does help with the load of the form after the initial launch. If I remember correctly, we had to “cache” it in each company and there was a limit to how many forms you could cache at one time before Epicor crashes. We have many users that work in multiple companies. Some users have found a nice middle ground with using cached forms, but many haven’t. It alleviates some of the pain but doesn’t fix the problem.

I think the biggest complaint is how long it takes sales to create a quote. I will focus there and start digging in. I’ll question my team more about what exactly they’re doing when they encounter issues, and maybe I can start pushing us away from the desktop client. If it’s just the desktop client that’s experiencing issues, and it’s going to be retired soon from what I hear, then maybe it’s for the best.

By chance, is your antivirus software Sophos?

Asking because we ran into this issue a couple of months ago, and had to switch to another product…

Sophos has now apparently acknowledged and mitigated the issue:



We also had this issue with our Sophos version and Epicor Kinetic (we are cloud) slowing Epicor way down. After troubleshooting, we found by going to Sophos intercept x version LTS 2022.4.3.2 worked well and our end users reported speed was back to normal.

Also, we found that the slowness issue with us was only when using the Epicor client and not using the web browser with Epicor, browser was unaffected by this slowness issue. Unfortunately at this time most of us can’t use the browser full time yet.

1 Like

Do you have the same slowness if you run the program as administrator (by right clicking on the shortcut and selecting ‘run as administrator’)?

I’ve run into similar slowness issues which were non-existent when running as administrator. It pointed to a permissions issue with the installation.

We use SentinelOne, we had Cybereason before that. I tested “run as admin”, no change.

More info about us, we have like 64,000 parts, 5k customers, and a quick query shows we have data all the way back to 2004. Could a big database or too many custom fields on a table cause issues like we’re seeing?

Edit: Realized that’s probably not the case as web access would most likely be affected as well.

1 Like

Are your client machines running Crucial SSDs? Crucial, Plextor and OCZ solid state drives are known to lock up. I’ve decommissioned a couple of problematic Crucial BX300’s. Just throwing that out there so you can rule that out.