Epicor Print from Remote Location

I have a BPM and Print routing setup to auto print Ship Tickets once they are imported. While I was onsite, it printed. In duplicates, but it printed. Now that Ia m at home, the BPM doesn’t print, and the routing works if I enter the order manually and select the print button. I am using a Net Extender so it should make it look like I am onsite.

FYI: When I import he orders it used to show up in the System Monitor that something was coming through, now it just shows nothing.

I assume you are printing to a different printer now?

I have tried different ones, but I have tried it original as well.

So the client is running on your local computer (the one at your fingertips)?

Can you access the desired printer from your local computer, using another program? Just checking to see if your local computer has full access to the network, or if it is limited to the E10 Client to App connection.

Yes, I have printed to it without the BPM.

You say nothing shows up in the System Monitor when printing is initiated from the BPM, when remotely connected. Not even under the Scheduled tab?

Try changing the BPM from PRINT to SUBMIT, with an archive period of 1 week set. To see if that creates Sys Monitor entry.

1 Like

@ckrusen I tried setting it to Queue in the BPM and noticed the first one I tried it came up in Reports tab in Sys Monitor, then it just disappeared about 10 minutes later. All subsequent attempts have not been successful.

@ckrusen @Jason_Woods Long story short, I have it printing now. This time, I am just using the BPM and, when done manually, it works. It is set up as when the ReadyToFull changes from false to true, print Ship Ticket. When I am importing the orders, suing the Epicor built order import, it doesn’t pick it up. Ideas on what I may be missing?

Is it a Data Directive?

Jason Woods

Yes it is.

What type and what are your conditions?

Standard on OrderHed. IF OrderHed.ReadyToFulfill has been changed from False to True then auto print. In auto print I have ShipTikcet selected, Auto Print 1 Auto Print 2

How are you Importing? Since this is a Client Printer, how will it know that that client has a printer (DMT, ESC, and REST don’t have this kind of info as far as I know). If you make a Server Printer, it will probably work.

I am using only my client printer for testing since I am not onsite. So maybe as a server it would work, is what you are saying, correct?

I always recommend a Server Printer when possible.

Changed it to Server Printer, still nothing. Its like its not picking up the imported order. AS if its not seeing the new order number and the change in it.

My next thought is can we say If there is an order on Orderhed, dated for today, with this exact Cust num, the print Ship ticket? I’ve tried a few ways I could think of and nothing has worked. So figured I’d ask and see what you thought.

when are you setting “ReadyToFulfill”? It would need to be after the lines are created.

So, the ReadyToFulfill is set during the import process. this was created by Epicor and I am not sure when it is set. I tried to do a trace on it and I do not understand what it is doing.

Anyway, I do have it printing, but it prints out incorrect amount. What it does is, lets say the import creates 25 lines, it prints 25 ship tickets of the first order. Not one for each order. This tells me something is off.

I bet it’s set at the beginning and not the end.

Jason Woods

Yeah, I thought so. Asked the guy who made it and he said it was the alst thing that was set with all orders being done at the same time.