Epicor Wont Copy to Excel

Hello all, randomly last week a user within my company lost access to export data from epicor into excel. It appears that when I do press the copy nothing happens. We had this issue in the past and it appears it was a permission issue. After doing what we did last time it did not fix the issue. Also did a reinstall and it appears it did no change. Ive always done a repair on office products and it appears it did not work. Not to sure if anyone else have had similar issues or not. Thank you.

My suggestion is to Right Click → Copy all Include Labels and then paste into a blank excel workbook.

Ours has been doing this for a year for random users, random timeframe for how long it affects them. Deleting cache, re-installing Epicor, clearing Office/excel cache, reinstalling office, all of the general obvious things seem to not really fix it. I don’t think it’s an Epicor issue specifically [probably some API hook], but there seems to be no rhyme or reason to it in my opinion.

Ahh I see. This is very unfortunate. You think it would stop like after an update or something. This is really bizarre because like you said it just happens randomly. Hopefully support from Epicor could comment and give us an idea on this.

That would be awesome. Maybe someone else on here has found a fix for it too, I’m sure we aren’t the only ones!

Speaking of, I found this post. Keys in at holding Alt immediately after clicking open in excel.

I have found for my users - the fix has been to login to O365 and perform a “Repair” - that usually fixes it.


1 Like

Going to attempt this and see what my user states. Thank you for that post.

Thank you. I’ve attempted this already multiple times and it appears it is still not working.

@DaveOlender said. We’ve also found this could be a memory issue; When a user has too many programs --or even Epicor windows-- open it stops the Copy to Excel option from enabling. Rebooting or closing unneeded apps/windows worked on those cases.

Hmm for the user we did a complete restart of the machine and only launched epicor and it still did not work sadly.

Tried this however it did not work. Thank you Logan!

I also tried it and it failed to work. I did read on some other posts that deleting and recreating the Windows profile seems to fix it, so something is getting hosed up on the actual Windows user :confused: Quite a lot of work to do, if it is going to be a recurring issue. Many theories floating around EpiUsers on this apparently…

Sad, is there any way for us to recreate the issue on like a test machine have you found or is it pretty much just random.

I don’t know a way to induce the issue but I have plenty of people willing to try things out… funny for such a non-impactful issue it sure drives the users mad not being able to use it.

Yes indeed… And man recreating the Windows User. I am not wanting todo that. I feel like that would just cause greater issues down the road. Its quite annoying that it happens randomly.

Have you tried the whole windows folder path permissions?

Just an update. I did nothing but it appears to be working again after 2 and half weeks. Unsure why.