ERP Function with output parameter not working

Hello,
In Kinetic 2023.2.3, I am having trouble calling an ERP function with an output parameter. For testing, I have an empty function with an output parameter. When I ran it, I kept getting an exception for an unknown parameter. Has anyone encountered this issue?

Thank you,
Peter

Are you calling this from a BPM? Or a Kinetic Form? We’ll need some details to know where to look.

What do you mean by “Empty”. Like you did nothing?

Via the Kinetic Form. I am doing a Kinetic form customization and attempting to invoke the ERP function. I also tried to test it via the Schedule Epicor Function Kinetic form and got this error; however, no error when running via the Schedule Epicor Function classic form. I am assuming the classic form is using V1 instead of V2 of the service call.

Thank you

Yes, I tried with nothing in the function designer besides having the response parameter.

I also tried setting the output response only to a value.
image

Go run it in swagger and let us know what happens.

1 Like