Error debugging with Visual Studio, won't attach to process automatically

When I try to debug customization in Epicor 9.05.701 using Visual Studio 2010 here’s what happen:

When I select the “Debug with Visual Studio option” in the customization screen, the visual studio debugger starts normally, opening the .cs file containing the code while the Epicor customized screen loads, then I get an Epicor error:

Error Detail

Exception from HRESULT: 0x8971001E

Stack Trace

at EnvDTE80.Process2.Attach2(Object Engines)
at Epicor.Mfg.UI.Customization.VisualStudioHelper.AttachToProcess(DTE2 instance, Int32 processId)
at Epicor.Mfg.UI.Customization.CustomizationDebugHelper.FilteredDebugInto(Int32 processId, String fileName, Int32 line, Int32 character)
at Epicor.Mfg.UI.Customization.OleMessageFilter.DoInFilter[TResult](Func`1 action)
at Epicor.Mfg.UI.Customization.CustomScriptManager.DebugIntoCustomCode(String fullSource, String sourceFileName)

I click ok on the error message and the screen finish loading normally. I then have to go in Visual studio, in debug menu I select “Attach to process” -> MfgSys64.exe

And I can Debug this way. But if I stop the debugger, the option to debug won’t be available again until have restarted Epicor client… I would say that slows debugging the process a little… :wink:

Any ideas on this ?

Don’t use MfgSys64… its awful and hateful and Epicor doesn’t recommend it. Use the regular client (32 bits) and your life will be much easier, I wager that’s why your debugger won’t attach either.

Hi Jose,

Following your post, I have just tried with the 32 bit client, and unfortunately I get the same error.

That could be the subject of another post I guess, but I wonder why you say the 64 bit client is awful. It has fix a couple of issues here…

Well I was being hyperbolic but the 64Bit Client has always been recommended against by Epicor unless you absolutely need it to fix a specific issue.

Ok I understand. If I remember correctly, we had crash issue under specific circumstances with the 32 bit client, that why we were suggested to try the 64bit.

1 Like

Hello, I got the exact same problem with Epicor 10. Did you find a solution? Thanks.

Hi Alexandre,

Yeah figured it out not so long ago, it was my Visual Studio language settings. As I am in Quebec I had to use the french version, but it seems it does not work with Epicor.

I was able to reinstall the english version, and now it works fine !

Hope this helps.


My Visual Studio 2015 was in french… reinstalled English version instead, and it worked. Thanks for the tip!

1 Like

J’ai eu la même erreur …je confirme que le problème est l’installation en francais de VS.
10.2.600 avec VS Pro 2017. !

Ré-installer en anglais a réglé l’erreur.

Même sous Kinetic classique! (2022.2.4)