Excel REST Odata retrieve could not establish trust relationship

I am trying to use Excel to retrieve data using OData and I get an error message:
Odata: Request failed: the underlying connection was closed: could not establish trust relationship for the SSL/TLS secure channel.

I am able to get results using just a browser:

However, when i try to connect from Excel i get the trust relationship error.

I went into the Excel Trust Center and added a Catalog to that URL however, i still get the trust relationship error.

Anyone solved this issue before?

I’m not sure if this is a server or client issue?

Any help greatly appreciated.


It’s due to Excels high level of trust required on HTTPS Security - above and beyond what Browsers require.

I assume this is a self signed cert to ermc-sql1?
Is the ‘signing cert’ in Trusted Root Certification Authorities?


You’ll need a valid SSL Cert, excel is super picky about certs. Try let’s encrypt for a free / valid SSL cert.


Mr. Bart: Yes this is a self signed Cert on the server - however I am running Excel on a client.

I must admit I am not an expert on “Trusted Root Authorities” - I could not find that reference in the Excel Trust Manager.

I remember setting up a self signed Cert when I did the install - Do I need to reference that?

Or as Jose suggested - am I better off trying to setup a “valid SSL”?


Yes and on all your servers and not just the Epicor one. It’s really becoming a best security practice.

Mark W.


Check out this thread. It is a really long read, but some of the security stuff is discussed in there.

Lets Encrypt will work if your server does not have internet access for them to verify you have control of it?


If this server will only be accessed internally, you can do what @Bart_Elia suggested, add your server self-signed cert to your Active Directories Trusted list so computers in the network will trust the cert.

1 Like

This helped me! REST was working on my workstation but no others. I looked and I had a certificate installed but no one else did. I believe XL Broadcast must have installed one. Thank you very much!!

I am getting the same error and trying to troubleshoot the problem. In the documentation it says you need SSL on the server could this be my problem?



yes, you certificate either not trusted, like when it is self-signed, or does not correspond to URL you use in this call.


I went ahead and created a new topic so as not to confuse this one so if we could switch to that one and go on.

Excel and REST - getting started - ERP 10 - Epicor User Help Forum (epiusers.help)

Sorry for the Necro but in our case we needed to use the FQDN to get REST working with Excel as our Cert was setup with that.

https://{servername}/{EpicorAppServerName}/api/v1/BaqSvc/ABCCodes wouldn’t work
https://{servername.companyname.com}/LIVE/api/v1/BaqSvc/ABCCodes worked great!