Failed to install Epicor Data Discovery

Good day

Can you please assist this. I am running epicor

I am trying to install the Epicor Data Discovery, below are the options I have put, most are default anyway

When I click deploy, I get an error that says “Failed to install Epicor Data Discovery”. The event log does not provide any useful info, it just says Epicor Data Discovery failed


Please use custom account instead of local Services for application pool

Hi Sanjeev

I have put a domain account for application pool but still the same error persists.



Looks like you got it installed. You can review the log file it generates in the following path:

…ERP10\ERP10.2.200.xx\SupplementalInstalls\Data Discovery

In my own personal experience, EDD usually does not install correctly because of some kind of Permissions/Authenication issue on the IIS-side.

Yes, and its working fine

I have tried to deploy EDD a couple of times, using also the last screen shot that sanjeev sent but the same message is still coming up. Here is the last portion of the EDD logfile. I can’t see why its failing to install. Maybe someone can…

Property(S): INSTANCEID = DontUseThis
Property(S): DBEXISTS = true
Property(S): AUTH_VALIDATE = false
Property(S): WEB_PAGE =
Property(S): WixShellExecTarget = [WEB_PAGE]
Property(S): IS_SILENT = true
Property(S): DATABASE_EXISTS = false
Property(S): REST_SITE = Epicor.BI.DataDiscovery.REST
Property(S): EXISTING_SITE = 1
Property(S): IIS_WEBSITE_PROPERTY = Default Web Site
Property(S): WixQuietExecCmdLine = “[SystemFolder]inetsrv\appcmd” “recycle” “apppool” “/[APP_POOL_NAME]”
Property(S): Manufacturer = Epicor Software
Property(S): ProductCode = {33B74B4E-0F58-475F-9BB8-DD6A1C2D0114}
Property(S): ProductLanguage = 1033
Property(S): ProductName = Epicor Data Discovery
Property(S): ProductVersion =
Property(S): DefaultUIFont = WixUI_Font_Normal
Property(S): WixUI_Mode = InstallDir
Property(S): ErrorDialog = ErrorDlg
Property(S): MsiHiddenProperties = CommitIIS7ConfigTransaction;CommitMetabaseTransaction;ConfigureIIs7Exec;ConfigureIIsExec;CreateDatabase;DropDatabase;ExecuteSqlStrings;ExecXmlFile;ExecXmlFileRollback;RollbackCreateDatabase;RollbackExecuteSqlStrings;RollbackIIS7ConfigTransaction;RollbackMetabaseTransaction;StartIIS7ConfigTransaction;StartMetabaseTransaction;WriteIIS7ConfigChanges;WriteMetabaseChanges
Property(S): MsiLogFileLocation = C:\epicor\ERP10\ERP10.2.200.0\SupplementalInstalls\Data Discovery\Edd.log
Property(S): PackageCode = {0140B22E-F861-4826-A9D7-F90238476F94}
Property(S): ProductState = -1
Property(S): PackagecodeChanging = 1
Property(S): LICENSE_ID = 67e0a800-85d2-4a17-bdd4-b1dd31a137cb
Property(S): APP_POOL_IDENTITY = SpecificUser
Property(S): WEBSITE_PORT = 443
Property(S): HOST_NAME =
Property(S): CURRENTDIRECTORY = C:\Windows\system32
Property(S): CLIENTUILEVEL = 3
Property(S): CLIENTPROCESSID = 8000
Property(S): VersionDatabase = 200
Property(S): VersionMsi = 5.00
Property(S): VersionNT = 603
Property(S): VersionNT64 = 603
Property(S): WindowsBuild = 9600
Property(S): ServicePackLevel = 0
Property(S): ServicePackLevelMinor = 0
Property(S): MsiNTProductType = 3
Property(S): WindowsFolder = C:\Windows
Property(S): WindowsVolume = C:
Property(S): System64Folder = C:\Windows\system32
Property(S): SystemFolder = C:\Windows\SysWOW64
Property(S): RemoteAdminTS = 1
Property(S): TempFolder = C:\Users\EPICOR~1\AppData\Local\Temp
Property(S): ProgramFilesFolder = C:\Program Files (x86)
Property(S): CommonFilesFolder = C:\Program Files (x86)\Common Files
Property(S): ProgramFiles64Folder = C:\Program Files
Property(S): CommonFiles64Folder = C:\Program Files\Common Files
Property(S): AppDataFolder = C:\Users\epicorservice\AppData\Roaming
Property(S): FavoritesFolder = C:\Users\epicorservice\Favorites
Property(S): NetHoodFolder = C:\Users\epicorservice\AppData\Roaming\Microsoft\Windows\Network Shortcuts
Property(S): PersonalFolder = C:\Users\epicorservice\Documents
Property(S): PrintHoodFolder = C:\Users\epicorservice\AppData\Roaming\Microsoft\Windows\Printer Shortcuts
Property(S): RecentFolder = C:\Users\epicorservice\AppData\Roaming\Microsoft\Windows\Recent
Property(S): SendToFolder = C:\Users\epicorservice\AppData\Roaming\Microsoft\Windows\SendTo
Property(S): TemplateFolder = C:\ProgramData\Microsoft\Windows\Templates
Property(S): CommonAppDataFolder = C:\ProgramData
Property(S): LocalAppDataFolder = C:\Users\epicorservice\AppData\Local
Property(S): MyPicturesFolder = C:\Users\epicorservice\Pictures
Property(S): AdminToolsFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools
Property(S): StartupFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
Property(S): ProgramMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu\Programs
Property(S): StartMenuFolder = C:\ProgramData\Microsoft\Windows\Start Menu
Property(S): DesktopFolder = C:\Users\Public\Desktop
Property(S): FontsFolder = C:\Windows\Fonts
Property(S): GPTSupport = 1
Property(S): OLEAdvtSupport = 1
Property(S): ShellAdvtSupport = 1
Property(S): MsiAMD64 = 6
Property(S): Msix64 = 6
Property(S): Intel = 6
Property(S): PhysicalMemory = 32723
Property(S): AdminUser = 1
Property(S): MsiTrueAdminUser = 1
Property(S): LogonUser = epicorservice
Property(S): UserSID = S-1-5-21-2491120017-1642073427-608602363-2472
Property(S): UserLanguageID = 1033
Property(S): ComputerName = AOLOBSEP03
Property(S): SystemLanguageID = 1033
Property(S): ScreenX = 1024
Property(S): ScreenY = 768
Property(S): CaptionHeight = 23
Property(S): BorderTop = 1
Property(S): BorderSide = 1
Property(S): TextHeight = 16
Property(S): TextInternalLeading = 3
Property(S): ColorBits = 32
Property(S): TTCSupport = 1
Property(S): Time = 15:20:41
Property(S): Date = 2/19/2019
Property(S): MsiNetAssemblySupport = 4.7.3062.0
Property(S): MsiWin32AssemblySupport = 6.3.9600.16384
Property(S): RedirectedDllSupport = 2
Property(S): MsiRunningElevated = 1
Property(S): Privileged = 1
Property(S): USERNAME = Windows User
Property(S): DATABASE = C:\Windows\Installer\128efa.msi
Property(S): OriginalDatabase = C:\epicor\ERP10\ERP10.2.200.0\Updates\ERP10.2.200.12\SupplementalInstalls\Data Discovery\EDD_1.0.msi
Property(S): UILevel = 2
Property(S): ROOTDRIVE = F:
Property(S): CostingComplete = 1
Property(S): OutOfDiskSpace = 0
Property(S): OutOfNoRbDiskSpace = 0
Property(S): PrimaryVolumeSpaceAvailable = 0
Property(S): PrimaryVolumeSpaceRequired = 0
Property(S): PrimaryVolumeSpaceRemaining = 0
Property(S): INSTALLLEVEL = 1
Property(S): SOURCEDIR = C:\epicor\ERP10\ERP10.2.200.0\Updates\ERP10.2.200.12\SupplementalInstalls\Data Discovery
Property(S): SourcedirProduct = {33B74B4E-0F58-475F-9BB8-DD6A1C2D0114}
Property(S): ProductToBeRegistered = 1
MSI (s) (0C:8C) [15:20:41:786]: Note: 1: 1708
MSI (s) (0C:8C) [15:20:41:786]: Product: Epicor Data Discovery – Installation failed.

MSI (s) (0C:8C) [15:20:41:787]: Windows Installer installed the product. Product Name: Epicor Data Discovery. Product Version: Product Language: 1033. Manufacturer: Epicor Software. Installation success or error status: 1603.

MSI (s) (0C:8C) [15:20:41:793]: Deferring clean up of packages/files, if any exist
MSI (s) (0C:8C) [15:20:41:793]: MainEngineThread is returning 1603
MSI (s) (0C:6C) [15:20:41:796]: RESTART MANAGER: Session closed.
MSI (s) (0C:6C) [15:20:41:796]: No System Restore sequence number for this installation.
=== Logging stopped: 2/19/2019 15:20:41 ===
MSI (s) (0C:6C) [15:20:41:820]: User policy value ‘DisableRollback’ is 0
MSI (s) (0C:6C) [15:20:41:820]: Machine policy value ‘DisableRollback’ is 0
MSI (s) (0C:6C) [15:20:41:820]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (0C:6C) [15:20:41:820]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (0C:6C) [15:20:41:820]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (0C:6C) [15:20:41:821]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (s) (0C:6C) [15:20:41:822]: Destroying RemoteAPI object.
MSI (s) (0C:A8) [15:20:41:822]: Custom Action Manager thread ending.
MSI (c) (40:50) [15:20:41:823]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (40:50) [15:20:41:824]: MainEngineThread is returning 1603
=== Verbose logging stopped: 2/19/2019 15:20:41 ===

I ran into something similar yesterday.
What do you get if you browse here? https://YourFullyQualifiedDomain/YourAppServer/TokenResource.svc

Mine ended up saying something about the authentication since we’re SSO.
I had to change the following from “None” to “Windows” in the app server’s web.config file.
Always make a backup of your web.config if you decide to change something

<!--REST/OData - Authentication: Epicor Username - Channel encrypted via https  -->
        <binding name="RestHttps" transferMode="Buffered">
          <security mode="Transport">
            <transport clientCredentialType="Windows" /> <<<< Changed this value
          <readerQuotas maxArrayLength="2147483647" maxBytesPerRead="2147483647" maxDepth="2147483647" maxStringContentLength="2147483647" />

Hi Willetta

I have changed the webHttpBinding section in the web.config file from None to Windows but still can’t get EDD to install.

I have also edited the anonymous authentication credentials to Application pool identity. After typing the url in internet browser


I get the following error;

Has this problem been solved?

I’m having the same problem with getting EDD installed.

Every time I try to install it I get this error:

and when I go to EDD log file, the last sentence before stopping is “MainEngineThread is returning 1603”

I did change the client credential type from “none” to “windows” as @hmwillett suggested but still the same problem.

Did you try this?

I don’t have it installed but tried it none the less and it says that the site can’t be reached.

when I try to use the app server url instead of the FQDN and the instance name instead of the app server it displays this page:

Hello @aamerabuarja,

I just recently went through several unsuccessful attempts at deploying EDD until I worked with Epicor and finally got a successful install. Here are some instructions that I hope might be helpful to you to get this working. Please note these are things that worked for us in our environment. Yours may be somewhat different but hopefully this will help give you some things to test and try in order to get it working. Otherwise I would suggest entering a help ticket with Epicor cause they helped me to finally get EDD working.

Re-install EDD and Pre-Deploy Settings.pdf (619.6 KB)


Thank you for your help, but I’ve actually done some of those steps before and did them again in the same sequence as demonstrated in the PDF, it generated the same result.

even though everything checks out according to the steps in the PDF.

Just to add to @tomdomurat comments. If you are running a version with an update applied to it then the log file will be in the ERP10\\Updates\\SupplementalInstalls\Data Discovery directory.

I’m actually suffering from a the following warning
EDD installer identified (and bypassed) potential security vulnerabiliy.
Unable to discover current default SSL/TLS certificate protocol. Please verify this server uses tls1.2.
The server is windows 2016 which tls1.2 is supposed to be enabled by default.

So I was suffering from problems during the Validation phase of the deployment with a “Installer has detected SSL/TLS vulnerability.” And messages mentioned in the last post.

I ended up creating a new Self signed certificate, and set it up in the binding of the website in IIS. as below

Once I had done that and made sure the SSL Domain Name matched the Subject Alternative Name in the certificate that I applied to the website. Ideally I want to use our wildcard certificate, but testing that will have to wait.

Once all that was fixed it worked. One thing during my troubleshooting, I noticed if I used the same application pool as the app server it would fail as well. I suspect because the app pool gets shut down during the install process (this gave me token errors).

There is useful information here in Epicare.;sys_id=ea32b993db9d1bccbea3fba9bf961900

I hope this helps someone.

1 Like


if possible, please provide the remote session for the same