Financial Reports Print Preview Issue

I am having an issue with Print Preview for Financial Reports specifically. We recently upgraded to 2021.1 from Epicor 9. Our financial reports which were built with Financial Report Designer made it across for the upgrade but there are some issues that I am seeing between our Production environment and our Test environment. Our test environment is able to print preview the preexisting reports without issue but our Production environment will not print the reports at all. When I go to System Monitor to check the status of the report in our prod environment it shows as completed in Historical tasks but in the Reports tab it shows Error: Report selected does not have any data; when I try to print preview it to get more error details it crashes my Epicor session. The main difference between our Test and Prod environments is that the Prod environment has a separate Task Server while the Test environment just has App and SQL. I am thinking there is something missing in my Task environment, does anyone have any ideas as to what could be going on?

1 Like

Shawn, did you import the reports from a test environment or were they brought over directly from the migration.

We had this EXACT same issue. Our controller had to start over and create a new financial report and then it started working.

They were brought over with the migration. The reason why I am still not convinced that is the issue is because the same report works in our Test environment. I have tested creating new reports as well, I still get the same problem.

An additional detail that I forgot to mention is that the Financial Report Styles location is EpiFin, from my understanding that is an AutoPrint trigger for Epicor. My hunch is still the task server not being set up correctly to run that report.

Okay yeah then your situation does sound a bit different. We had an issue with the import/export of financial reports from our test environment to our live environment.

One thing that I hadn’t tried before was running the Financial Report in Epicor on the Task Server, I just did that and the report worked.

1 Like

Does anyone else have any thoughts on this problem? I have opened a ticket with support previously and all suggestions that were given had been tried. I tried to communicate that to the support team but it ended up being repeated solutions.

I will include some screenshots of the process to see if that helps.

Open Financial Reports. Select IncomeStatement Report. Select Comparat Column Set. Enter Fiscal Year 2022 then Period 9. Select Report Style Print Report. No filters are applied.

Click the Print Preview Button.
After checking the System Monitor the report is in Historical Task as completed but in the Reports tab is shows Error: Run in Preview Mode from System Monitor for details. The report selected does not have any data. Something of note when the Report Location displays the Server name is actually cutoff by one character. Could that be something? Where would I change that if I can change it?

When I try to run the report in preview mode it crashes the entire client. I can never get it to work.

As I stated above, I can run this report from the Task server using the same settings and it will work fine. That leads me back to being suspicious of the movement for this report from the App server to the Task server. Running it on the Task server produces the report but the report location is still missing the one character from the server name so doesn’t seem like a problem but I am not sure.

Is EpiFin a process or DLL that would need to be in the right location for the report to work correctly?

While I have a work around for the time being, I would love to get this problem fixed.

I got a solution from Epicor Support and it worked! I am a little bummed that I didn’t think of this before but what support suggested was to take the Client Data Directory path and copy it into the Server Data Directory. Easy as that.

1 Like