GetRows whereclause weirdness (Or am I going crazy Or doing something dumb?)

So I am using the BL tester to check the where clause I am using for an integration task I am working.

As a test I ran this query. With the where clause on the resourceCal set to SpecialDay > ‘2021-01-08’ (8th Jan 2021)

The results it pulls back don’t match the where clause. The highlighted record has SpecialDay of 6th Jan 2021 which when I check my calendar is NOT greater than 8th Jan 2021 ?!@?!


What are the results when you do the query in SQL or BAQ?

This is the result in SQL. It returns the expected results (without the records with SpecialDay before 8th Jan 2021)

At the start, I thought it maybe due to the US date format, but if the SQL returns the correct results, then it must be something else.

Maybe we both are going crazy. :confused:

Have you tried GetList instead?

The GetList method doesn’t return the full dataset so doesn’t have what I need.

I also tried a few other where clause’s in the whereClauseResourceCal and they didn’t work either. It appears the where clause is ignored - ticket submitted to Epicor.