GL Import exception

I’m trying to figure out what’s going on with my GL Import process. I have created a test file which is mapped based on the GL Import File Format template. Here’s what it looks like in text:

When I select the file and submit the process in GL Import, here’s the error it’s throwing:

When I go to the Journal Entry for the group ID, it looks like it attempted to create a journal header, but failed.

I’m positive I’m missing something, but any help is appreciated, thanks!

Not sure if it caused your error or if it would just use the date of the last row imported, but you have a different apply date for each journal line in your import file. Also, do you have any UD fields that you need to throw a comma in for maybe?

If you don’t need to use the GL Import process you can just load it up using the DMT which may be easier. Here are the columns from an old import template I used.


Thank you Mike, I might have to go the DMT route if I can’t figure this one out.
I changed the apply date to be the same day, but yielded the same results.

I havent done this for a while, but in E9, I had issues as well. I placed the file on the server and did the import from the server and it worked. I had to give my Accounting group access to the server and a shared directory. IDK, HTH.

Did you find a solution for this? I’m seeming to run into the same issue.
My HR person has followed the same procedure for months. The same steps no longer work. As a result our GL Journal Entry screen looks similar to your result.

Hey Ben,
I actually don’t remember…it’s been a while and I’m not sure what route Finance ended up taking. But, I’d be happy to share my documentation on it and example files with you.
GL Import Functionality.pdf (530.5 KB)
ExampleCSVWithData.csv (307 Bytes)
GLImportStructure.xlsx (14.3 KB)

Obviously your book probably has different segment mappings then mine but I am looking through my old stuff and it looks like I had eventually got it to work.

1 Like

Just solved my issue through Epicor Support.

The CSV file I’m trying to import ended up having an extra blank line on the end. Line 106 had comma separated data. Line 107 showed, but with no data.

Once I deleted and resaved, I can have a successful import.

Aaron, thanks for responding to this!

We are going to be moving to ADP for our payroll process and I am looking at the file and its format that needs to be imported into Epicor. Can you explain to me what the UDXXX01, etc fields were for? Is this something we will need to add or are these UD fields for your company?
Am feeling a bit in the dark… ugh. Any help is appreciated.

Hey Carol
From the help, it looks like these are just user defined fields as needed. I do not think they are required by any means…
We didn’t actually end up using this process, so I’m trying to recall the actual use of this process.
I did post some instructions for the import above as well as a couple of example files, were you able to get those to work?

1 Like


We need to supply ADP with the file format layout to use and they will send us the file and we will then import it. We will probably be testing it out in a week or so.

Thank you … crossing my fingers it will work.

Do you mind if I ask what process you did decide to use?





I think finance decided to do it manually to be honest. I do recall it’s tricky to set up the right format but works ok after that.

Okay … thank you Aaron.

Not sure how cumbersome it would be to do it manually, so I hope this works.