Incorrect Conversion Factor or UOM

We have a purchased material that had the wrong conversion factor entered and now we can’t change it. I found the same question (link below) for version 9 but the fix was shared offline. Anyone know what it was, if it worked and side effects?

In Part Entry there is a checkbox that is normally not on the form, do a UI customization and when you check this it will allow you to change the conversion. It will uncheck itself after you save. You may want to put some security on this field. The below screen shot is from E10 but this field is available in E9.


From what I understand, we are converting to E10 and this was question that I had, you can change the part UOM. You have to zero out the balance and then change it and then put back the inventory. One thing is I am not real clear on the ramifications to previous transactions against the part.

I don’t beleive it will effect prior transactions. I know it won’t effect current inventory values, so you may need to make qty adjustments if your conversion changes should change on hand values. I would confirm this in your test environment.


In my environment I tried this and it didn’t end up working. Here’s a pic:

From what I understand, you check the Override (I had to add this field manually) checkbox and then you can change the UOM conversion data. If that’s how it’s supposed to work, then it doesn’t…

Another pic:

Edit: I understand that in 10.1 we have Part UOM Conversion Maintenance, but even that doesn’t work:

If you want to change the conversion factor and the part is not too far along you need to unset the has been used flag. You want to make sure you have no quantities on hand and it is on not boms or jobs.

We try to catch these in the first few days of a parts existence, before any parttran records exist.

I have an updatable baq that I do this with in E9, but have not written it for E10 yet.


1 Like

We had UOM Conversion issues on parts we migrated form an older ERP too. PITA once the field is locked down.

I can totally see locking the Inventory UOM conversion factor but the sales ones made it hard for us to fix the issue. We did @gpayne has been used flag trick.

If anyone is wondering about the Override Checkbox, you can display it by doing a Personalization on the Grid and according to Epicor it will only work if you have no Demand out there…

  1. Check the Override checkbox and the Factor field should become editable.

Note: If the checkbox is not visible, please refer to Knowledge Base Article KB0029838.

  1. If this does not happen is because the part is being used, meaning that there is an open demand.

  2. The user will then have to Delete the Line from the Purchase Order and save it.

  3. Go back to try out step 7.

  4. Save and exit the screen

  5. Go back to Purchase Order Entry to add the line back

  6. The user may proceed to make the PO Receipt

It looks like the Override checkbox does not work in 10.1.600.19. I have used it in the past, but lately it is not working. I do not remember if I used it in E9 before and never on E10.

I have a test box for 10.2.300, will try there to see if it works.

Vinay Kamboj

That KB Article I pulled that from was written 30 days ago, I hope it works – because that is the route we are about to take to resolve an Issue :slight_smile: on 10.2.300 fingers crossed

I tried to modify the conversion factor of 2 parts with the Override checkbox, one succeed.
Another one’s conversion factor remains grey while I check the Override checkbox.
Their settings are basically the same, only difference I can tell is that the failing one is having negative running total, did a Quantity Adjustment to make it positive, doesn’t help.
They both have demand, open PO (not with this UOM).
Any idea?


I believe you cannot have any open transactions and quantity on hand for this to work.

Vinay Kamboj

Adjusted onhand of every warehouse to zero, closed the PO and Jobs in Time Phase so demand is now also zero.
Conversion factor remains grey :confused:

For us also the override check box does not work sometimes. It worked in E9, never worked in E10.1.600. Now we have 10.2.400, never tried. I’ll try when I have some time.

Vinay Kamboj