Initialize Custom Assembly Error

So I created a dashboard with a little bit of customization to the dashboard. However, out of 12 users, 2 users are experiencing this particular error.


Any ideas to why only 2 users are having this issue while no one else is? We tried clearing their client cache, deleting favorites or not using it at all, restart application pool, server reboot, etc. Nothing seems to be working. Once the user clears their client cache, it works for the day or until they close out of Epicor and come back in. Same error. So we have a temporary workaround by clearing the client cache, but it’s becoming an annoyance to the users. Just checking if anyone have any ideas.

What are the details of the exception?

1 Like

Did you do this? Clearing the cache doesn’t always (usually) remove old versions of customizations from the users computer. Sometimes versions are cleared automatically and works fine (your 10 users) but sometimes that old version hangs around like an old penny.

1 Like

Hey there!

Yes, it’s not often but does come up. We delete the 808 directory instead of drilling deeper into the folders these days. There has been a few cases where we had to clear out a users %appdata%\Epicor folder too – but that was a really weird case.