Issue with Global Customer

Anyone here that uses multi-company module have add any issues with a customer marked as global not showing up to link it at another company?

Never had an issue with it and all of a sudden I can’t see it on the other side. As far as I can tell the multi-company direct server process is working properly.

Did you try unlinking and relinking the global customer? We’ve had this issue where we had to relink it to show up correctly. You can also try restarting the task agents for both the parent and child company.

What do the Multi Company logs show?

I can’t link it in the first place. The Global checkbox is checked, but I can’t see it on the other side to link it.

Nothing at all, though I don’t recall it ever showing anything about linking customers either, or even anything in the ice.IntQueOut table.

Try restarting the task agents. If the multi-company log is showing inbound or outbounds not processing, then restart the task agents. You should be seeing in the logs outbound and inbound records being processed similar to below.

08/16/17 10:23:11 ( Multi-Company Process - 1 Outbound Records Published (450/001)
08/16/17 10:24:30 ( Multi-Company Process - 1 Inbound Records Received

Do you have basic or verbose logging enabled on the process? Based on your response about nothing in Ice.IntQueuOut table I would think something is not right with the process. Are there any errors in your app server log?

Sorry, I meant nothing in the log regarding this customer. Everything else is working normally. Process is running, just there isn’t anything to process about this customer as there’s nothing in the queue. Like I said though, I don’t recall if there’s supposed to be for a new global customer, so I’m not sure if the server process is used in this situation.

Are updates linking correctly for current customers? If so, can you delete and try creating the new customer again if outbound records are being processed normally in the parent company.

Currently linked customers are updating properly. If I change information in one company, it transfer to the other side.

Already tried recreating the customer but it’s still not showing up. Tried creating a new test customer and nothing either… I’ll try to recycle the application pool to see if helps at all.

Recycling app pool didn’t help.

Might be something in the set up. How many companies do you have?

Only two are set up for multi-company. Nothing has changed in the set up, has been working fine for over a year.

Check in External Company Maintenance that the ‘Send Customer’ option is still selected. Global Table Maintenance settings? Have you tried restarting the SonicMQ service?

Wow, that was it. This was a suspect and Send Suspect was not checked as opposed to the other ones. Now it makes sense. Thanks!

1 Like