Issues installing Enterprise Search in 10.2.600.3

Hello all, I keep receiving an error when deploying my enterprise search extension, I have tried numerous methods, obviously none successful. This worked prior to the update, Help would be appreciated, Thank you in advance.

The error reads

Deployment of Enterprise Search.
System.Exception: Failed to start service. Error: The Epicor Search Indexer service is starting.

at Ice.Tools.ServiceInstallerBase.StartService()
at Epicor.Search.Deployment.ServiceInstaller.InstallService()
at Ice.Tools.ServiceInstallerBase.Update(String& errorDetails)

Working with Epicor on this issue, we found that it was due to there being multiple Self signed certificates in the servers repository under Personal and Trusted root Certification Authorities.

You can find the mention in the Event Viewer for Windows as soon as you deploy the Extension under Applications, the Errors source is “Epicor Search Indexer” and the error reads

Service cannot be started. System.InvalidOperationException: Found multiple X.509 certificates using the following search criteria: StoreName ‘My’, StoreLocation ‘LocalMachine’, FindType ‘FindBySubjectName’, FindValue ‘’. Provide a more specific find value.
at System.ServiceModel.Security.SecurityUtils.GetCertificateFromStoreCore(StoreName storeName, StoreLocation storeLocation, X509FindType findType, Object findValue, EndpointAddress target, Boolean throwIfMultipleOrNoMatch)
at System.ServiceModel.Security.SecurityUtils.GetCertificateFromStore(StoreName storeName, StoreLocation storeLocation, X509FindType findType, Object findValue, EndpointAddress target)
at System.ServiceModel.Security.X509CertificateRecipientServiceCredential.SetCertificate(StoreLocation storeLocation, StoreName storeName, X509FindType findType, Object findValue)
at System.ServiceModel.Configuration.X509RecipientCertificateServiceElement.ApplyConfiguration(X509CertificateRecipientServiceCredential cert)
at System.ServiceMod…

Deleting them all, then recreating 1 self singed certificated and applying that certificate under the default site, bindings and port 443 then uninstalling, reinstalling the Enterprise Search under the Application Server Configuration Extensions resolved the issue.

Epicor will be creating a KB on this as a bug in this release of 10.2.600.3 and this is tied to an On Premise installation, not a Cloud installation.

Leaving this to help others that may face the same issue.

Hey Iggy I’m having the same issue as you on 10.2.600.5.
Is this supposed to deploy under its own site? Mine deploys under the Default website which has a wildcard cert bound to 443. I tried deleting all the other self-signed certs in the Personal and Trusted cert store, uninstall/reinstall but I get the same behavior. This is on prem as well.

1 Like

I apologize it took me so long to get back to you, I could not log in.
Have you checked your event viewer to see if you got similar messages to mine?
My problem was that I had it in too many places, so I deleted all of the certs, but one.

As for the site, it installs under “Default Web Site”

Hey Iggy
I ended up not installing enterprise search because of this. Oh well, I don’t think we were getting any value out of it and I haven’t heard a single complaint since removing it. I did try removing all the old certs to no avail.
Hopefully this post can help someone else who runs across it!

I don’t find it very valuable either, but it’s there if anyone “needs” it.

Geeez, I just realized you wrote 10.2.600.5, we just updated to .3 like 3 months ago… let us breath Epicor haha.

1 Like