Kinetic 2022.2.4 in modern mode I get Visual Studio greyed out

He just got Kinetic installed on a test server in 2 instances Pilot and Training
Pilot is running a copy of our prod DB.
Training is with default Epicor db.

I login with Modern type as we will start using the new version that way.

I am trying to test a customisation in debug mode, but my Visual Studio is greyed out.

I have 2017 installed.

Is there an option somewhere I need to set ?

thanks Pierre

You might need Visual Studio 2019 or 2022 in Kinetic. I haven’t really tried. Also do you have Community Edition or Professional? I had once an issue with Community Edition.

Make sure the Visual Studio display name in the Registry matches one of the ones Epicor is expecting: