Kinetic - Click Print Preview, need to open in Kofax, not MS Edge

Our users print-preview a lot in Classic, which opens the report in Kofax PDF where they can mark it up as needed.

In Kinetic, it seems print preview only opens in the browser, for us MS Edge. We want to click Print Preview in Kinetic and have it open the generated PDF in Kofax PDF instead.

I’m assuming this is impossible, but thought I’d ask.

Edit: Yeah, I spoke too soon. It works in Classic. Just tried the browser. No go.

Nope

Find a pdf file and right click on it on your desktop or some folder.
Choose properties.
Click Change, on the “Opens With” Option

Find Kofax, click save.

Works. Now all my pdfs preview with VS Code. Gotta change that back lol !

Been down that road. Nothing. Still just opens in a tab in the browser (we are using 2024.1 via browser only).

Maybe some other setting… digging…

Yeah, I spoke too soon. It works in Classic. Just tried the browser. No go.

Sorry :cry:

It’s these types of things that keeps making browser-only hard to swallow…

Check “Document Association Maintenance” see if pdf extension is pointing somewhere?
I user Autovue so:
image

Doc assosiations are for attachments not print previews.

My bad, my logic fell off the rails.

It’s not impossible, but to do it yourself would be a pain in the butt.

Adobe has this ability, it basically tells chrome to turn off it’s default handling of pdf and registers a custom handler with windows to open them.

You can build your own, but then you have other issues.

Beg them to add “Client Preview” in addition to “Client Print” to the edge agent.

They could make it work like classic preview and use the default file handler.

1 Like

Try this:

For chrome:

Settings → Privacy & Security → Site Settings → Additional Content Settings
→ PDF Documents → Change to Download PDFs

Restart chrome then try below:

Edge should be similar. Haven’t looked though.

Then this:

https://community.kofax.com/s/question/0D53m00006LBSdkCAH/has-anyone-successfully-set-power-pdf-as-default-so-when-using-a-chromiumbased-browser-google-chrome-or-microsoft-edge-the-pdf-opens-in-power-pdf-instead-of-the-browser-if-so-what-did-you-do-that-made-it-work-without-downloading-each-pdf-first?language=en_US

1 Like

Thanks. Yeah, we changed to “Download PDFs”, but it is a bit clunky… wait for it to download, click the open button. It’s not ideal, but is closer.

I’ll also check out that link.

Right now we’re trying to use the MS Edge Policy for “always open pdf externally” - Microsoft Edge Browser Policy Documentation | Microsoft Learn

1 Like

This is the way! In Firefox, it’s Settings, search “applications”, and it’ll be right there. Feels a little clunky but not more so than changing Windows default applications. Sometimes having to do that again after Windows updates revert them to MS products (yells at cloud).

1 Like

The Windows policy change ended up being the same thing as settings in MS Edge (“Change to Download PDFs”), which displays a download button after preview is clicked. This, then, opens the downloads folder popup and you have to pick the desired download to open in your desired PDF viewer.

However, that Kofax link points out that you can right-click on the download and choose “always open with system viewer”, which eliminates one step for the user.

So, they click print preview, wait, see the download button, click that, then it opens in desired PDF viewer. HOWEVER, they now have files being added to their downloads folder… we may add a script to purge these files, as they will add up quickly.

Thanks for the ideas.