Kinetic Layer: Disable button while executing OnClick event

Hi all,

I’ve created a Kinetic Layer with a button that executes an event. Eventually it will fire an Epicor Function. The problem now is that the button doesn’t get in a ‘disabled’ state while it’s executing the event. This makes it possible for users to click the button multiple times, which will result in the function executing multiple times.

I tried using the Property-Set component, but i wasn’t able to make it work. I tried ReadOnly/Enabled/Disabled properties, but none of them worked. Maybe I used the wrong syntax.

Does anybody have an example of how to make this work?

Thanks in advance,


Have you tried using a Data Rule instead of an Event to disable it?

1 Like

Hello John,

Thank you for your reply.
I haven’t tried that yet. Should I enter an EpiBinding to the button in order to do that, or does that also work on Controls?

Not sure exactly what you are trying to accomplish, but I was thinking that you could add a field as a counter and when it is clicked the counter goes up 1 and that would trigger the Data Row Rule. Yes, it works on Controls. If you look at out of the box ones, you can see they use the RR to hide things like the attachment and new icons.

1 Like

I will give it a try, thanks!

You’re going to want to do a combination of rules and events.

  1. Bind your button to a field (it doesn’t have to be real DB column)

  1. Add a row-update widget to your button click event that sets something like TransView.Disable to true. Add a second one after your function call that will set it back to false.

  1. Create a rule that checks the state of TransView.Disable and disable the column you bound your button to if true. This will auto reverse if false




Thank you!

This worked for me :slight_smile: