Kinetic (web) Entry vs Trackers - How to Setup to Customize Tracker

Goal: customize Order Tracker in Kinetic Web UI

I’ve heard that in Kinetic Web vs Classic there is a single “Program/Application” for both the Tracker and Entry sides (for exampe Sales Order Entry/Sales Order Tracker).

Looking at the Tracker Menu item in Menu Mainenance it looks like this:

Notice the Kinetic Application says “Erp.UI.SalesOrderEntry”
and if I search to try to change it there is no “Erp.UI.SalesOrderTracker”
but I have no Kinetic Customization specified

So when I launch Order Tracker, indeed I see a very limited version of Order Entry…makes sense so far

But what if I want to modify the Tracker side ?

Even without the Kinetic customization specified if I go into Application Studio it takes me to the customization I have specified for Order Entry…and it no longer functions as a Tracker

So how do I make a layer and customize it for a Tracker then ?

Even if I select the Base layer in Application Studio or specify it as the Kinetic Customization in Menu Maintenance I still get Entry (not Tracker) type behavior

In Kinetic, all* trackers are now just read-only versions of the entry screen.
If you wish to modify the tracker, just create a different layer and apply it to the menu path that is associated with the tracker.

*Screens that have groups (finance) have their own tracker programs separate from the entry ones.

Curious, have you tried this yet ?

I placed a layer on my tracker menu, (saved, logout, exited after 2nd try :wink: )
And when I launch the Tracker I see what appears to be the base tracker
(no customizations and yes, everything is readonly),

but yet, when I then launch application studio, it shows the selected layer as active,
and when I Preview it, everything is writable, so I don’t have a tracker but a strange mix

thx, Scott

Yup. Works fine.

This happens to me too, but when you deploy it, it will be read only because of that checkbox in Menu Maintenance.

I believe you, cuz that’s how it should work and your images clearly show it,

Do you ever get it when you put a layer on the menu and it just doesn’t take effect ?
It’s still bringing up tracker base not my layer (and the layer name is not in the address)

We get this intermittently here, just had another case this morning, I’ve (more than once)

  • saved the layer
  • published the layer
  • made sure it stayed selected in menu maintenance
  • saved in menu maintenance
  • logged out
  • exited browser
  • and retried

still back at base, only thing I can think of that’s left is clearing my browser cache, trying that next

Nope, that didn’t help… :face_with_thermometer:

thanks for helping tho !!!

I will mark your last as the solution

I’m only asking because I’ve done this to myself, but have you verified that you’re applying the custom layer to the menu item you’re actually trying to open?

Too often, I’ve applied the layer to, say, Order Tracker in Order Management, but have been opening Order Tracker from Executive Analysis.

Excellent, (I’ve done that before also), it didn’t occur to me because in Menu maintenance I went to Sales Management/General Operations/Order Tracker and when I launched it before I just used the big square box in our default main page layout (or whatever that’s called)…and ASSUMED that was the one

Lo and behold, that was the problem, something to remember for sure

Thanks again

1 Like