Machine.config settings per Performance and Diagnostic Tool

Working on our new server for 10.2.200.5. I get the following message from the Performance and Diagnostic tool,
"Fail - Please change the following section to your machine.config file to be like the following <system.web> <processModel autoConfig="false" minIoThreads="600" minWorkerThreads="2" maxIoThreads="700" maxWorkerThreads="40" /> ... </system.web>"

I accessed the machine.config file in “C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config”. The original processModel line was:

<section name="processModel" type="System.Web.Configuration.ProcessModelSection, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" allowDefinition="MachineOnly" allowLocation="false" />

I added the autoConfig=“false” minIoThreads=“600” minWorkerThreads=“2” maxIoThreads=“700” maxWorkerThreads=“40” at the end of the line just before the />. Restarting the app server I received an error that autoConfig was not a valid option.

Am I making changes in the wrong place or is there something I am misunderstanding?

You should have a section towards the bottom of the machine config that is already established. You replace this. The pic below as the vanilla config and this is where you would put the changes.

image

2 Likes

Thanks Dan. I should know better than to assume I was in the right place.

Hi, may I know where to find the machine.config file and check on this setup, recently we also move the to new VM environment for our Epicor 10.2.400, and we face the same issue on this.

C:\Windows[Microsoft.NET](http://microsoft.net/)\Framework\v4.0.30319\Config