Menu maintenance - how to restore original menu item RESOLVED


I seem to have lost the original (system) version of the Method Tracker and I need to know how to get it back. Here’s what happened:

Method Tracker is NOT included under Executive Analysis with all the other trackers. In order to make it available to non-Engineering folks, I created a copy to put in the Trackers folder under Executive Analysis. Or, at least I thought I did. And I remember checking to ensure that it was a copy and that I had not moved the original.

But the original Method Tracker is no longer visible in Engineering Menu, which means the Engineers have to go elsewhere to find it. How do I put the original (system) version back in the Engineering menu?

When I look at the Menu table (via a BAQ), the system Method Tracker record appears to be there, with the proper parent menuID (SEMN3000) and the original order sequence (85). But it doesn’t appear in the tree view either in Menu Maintenance or in the user interface.

The copy does appear in the Trackers section of Exec Analysis, but I really want to restore the system version to its visible state.

When I made the copy, the sytem did not require a new MenuID, it just required a unique OrderSequence and that the module be UD instead of SE.

The DoNotDisplayInMenu flag is false.

Both versions have the same Security ID: SEC659.

The Parent Menu ID of the system menu is SEMN3000; the ParentMenuID of the copy is XAMN7000.

Any thoughts on how to handle this?



If the original menu item still exists in the same place, I’d suggest
looking at the security settings to ensure your engineering team is
“allowed” to even see it.

They are allowed. I can’t even see it and I have access to everything.

But you do see it in Menu Maintenance?

Also check the highlighted settings

And if it is gone totally then spin up your Demo version and check the menu maintenance for the information.

If you are really lazy you may be able to add the menu to a solution then export/import to your system. I have not tried this, but unlike E9 it appears you can add any menu not just UD ones. Happy to be corrected on this.

Thanks for those two bits of info. No, I can’t see it in Menu Maintenance. I have downloaded the Menu table in a BAQ to get what information I have about the system version.

In the system version (the one I want back):

  1. The Company field (corresponds to the Owning Company field in the UI) is empty.
  2. The Enabled field is = TRUE
  3. The CompanyVisibility field = 10 (no idea what this is; do not see a similar table in the UI.
  4. I can’t tell what field in the Menu table corresponds to the All Companies checkbox in the UI. There is no DB field in the Field Help. The EpiBinding is MenuM.AllCompanies

In the UD version (the copy that is currently in with all the other Trackers):

  1. The Company field (corresponds to the Owning Company field in the UI) is populated with our company ID (there is only one company) and it is populated in the UI.
  2. The Enabled field is = TRUE (and is checked in the UI)
  3. The CompanyVisibility field = 0 (still no idea what this is; do not see a similar field in the UI)
  4. The All Companies checkbox is empty and greyed out in the UI. Still don’t know what the field in the table is, if there is one.

Simon -

I have the information from Pilot. What I don’t know how to do is update a system record. Unless an updatable BAQ? That seems a little risky.

I would love to be able to import the version from Pilot. Will investigate.


If you have a version of the menu item (say like one you’ve moved) - you can copy it and paste it in the new location I believe.

Worst case, look at the info from the pilot on the screen I showed earlier, then in menu maintenance, create a new menu item and match the info in the fields especially the seq and program

1 Like

That was my original thought, but it won’t let me create an SE menu item a “user defined” one has to be UD. And I can’t use the same sequence because that one is already in use by the system version.

I also can’t create a system menu – that flag is greyed out. I think that I have to change the properties of the existing system menu since it’s still in the database. Have opened a case with Epicor; we’ll see how that goes.

Will update this thread with their information as well.

1 Like

Resolved: delete the copy (it had the same MenuID) and the original will return.

Here is what happened (so that someone else can avoid this situation)…

In Menu Maintenance, under the Actions menu, there are two copy options:

Copy to Current Company – this creates a copy of the item with the same MenuID and assumes you want your version to be used in place of the original system version (this is what I had used). Since your copy has the same MenuID, Epicor displays your version and not the original one.

Copy to New Menu - this creates a copy of the item with an empty MenuID and assumes that you really do want a copy to be put somewhere else. You then have to update the Parent Menu ID and Order Sequence to put the copy where you want it.

Hope this is helpful to someone.


Can you mark it as solved?..

1 Like

Sure. How do I do that?

As soon as I posted that comment I knew you would ask. I was rushing around and didn’t get a chance to edit my post. Then I saw it had been marked and forgot.

Anyway for future reference here is a link in from the site FAQs Mark Topic as solved - FAQ - Epicor User Help Forum