MES buttons not active

We are testing E10 to go live in 2 weeks. We have a group testing MES this week. They have reports a few buttons not active in MES. Has anything changed in E10 to active buttons in MES. THe user has Production Worked checked but is missing the following buttons…Non-Conformance and Request Entry (under Service)

Look at Employee Entry make sure the Employee Craig, has the right flags, he might need more than just Production. Also in 10.2 there is a new MES Security Entry Screen as well you should look at.

Check Employee Entry - Tab: Production Info

Ok thanks. I did try some of these on the Employee Record.

I was able to active some buttons but I noticed the Non-Conformance was grayed out. I can’t modify it at all for the user. They are set as a production worker in Employee maintenance.

I do have those checked and the Non-Conformance is still unavailable. I must be missing something.

It’s a combination of the Employee Checkboxes and the Username you use to login into MES (The Epicor Username). Make sure the User also has access in the Full Epicor Client to the Non-Conformence Menu Items.

That is why many companies use a “Generic MES” User such as “Shopfloor” and relate it to an Employee ID / Workstation.

1 Like

That is what we are doing. We have a shop generic log in and then the user puts in their ID to log in. The generic account does not have an Employee record.

How do you get them to relate to each other?

I don’t think I wrote that out right, can’t relate a generic to many… So if you login to the Full Client with that Generic ID, does that full Client have access to the Non-Conformance Entry Screen?

Ok I got ya. Yes that generic shop user has access to the Non-Conformance Entry screen.


In my case it only is available if the user is a “Material Handler”, perhaps it is only meant for Mtl Handlers

I added him as a material handler but still not active.

just odd because under MES security Maintenance the Material and Production are checked.

I had an issue where I needed to activate some licensing to get buttons working.
I think it was Advance production and something else.

What happens if you log into the mes in developer mode. Similarly what happens if you log in to the mes as the manager user. Could be you have a saved a custom version of this screen with the buttons greyed out.

Also if you start a production activity do any of the buttons become active?

However as hasokeric says it is most likely the employee record or the epicor user account

It is grayed out for me and I have access to everything. (I should anyway).

No customizations.

What happens if you go into the mes in developer mode. Create a new shortcut to the MES with -MESC at the end - see below as reference

C:\Epicor\ERP10.0Client\Client\Epicor.exe /Skip /config=E10TEST.sysconfig -MESC

Login as manager and check, make sure you load with no customisation/personalisation and see if the fields are enabled.

In menu maintenance -I’m assuming the menu structure is still the same - under production management | data collection, reset permissions for all sub menu so that all users have access.

Also one thing you haven’t shared a screen shot of is the detail tab for the employee record - the associated roles need to be checked against the employee - can you per below - we are on a slightly older version on E10 than you but principle should be the same

Any one out there on 10.2.300.3 and have Non-Conformance working??


I can replicate what you see when I go into the employee tab of the employee screen and remove everything but the production worker selection from an employee - irrespective of whether you have selected report non conformance on the production info tab. If I subsequently check material handler on the employee tab the logged in user has extra buttons including non-conformance.

Can you confirm that you have you tried checking the material handler field for the employee you are testing with?

Yes I did have both Production and Material checked.

Kimberly, are you Multi-Company?

If you start production activity on a job and then end activity do you have the option to record a non conforming quantity - as opposed to accessing the non conformity screen itself via the mes.

Back in the full E10 client if you do above does the non conforming quantity you logged via end activity appear in the list of non-conformities?

Just trying to establish if any of the non-conformity functionality is working.

What do you have checked on this screen for the employee? I can confirm this works in 10.2.300.3 and these are the check boxes that control this. Report Quantity must be checked to enabled selection of the others. If still grayed out can you launch non-conformance from the regular menu and save an entry?