Method directive calling function...(Solved)

I have a previously existing method directive tied to a checkbox form customization (JobHead.JobReleased to be specific).

My method directive calls a function, which was working fine…
until I added a parameter to the function, and made the corresponding change in the method where the function is invoked.

I’ve tried multiple times checking syntax, saving, demoting/promoting the function.
I even tried deleting the step in the method and recreated,
and also tried copying the function and pointing the method at that.

in all these cases when the form checkbox is checked and the method is invoked I get the following error:


the detail is as follows:

epicor obviously thinks I have a parameter mismatch when calling the function

this is my method’s invoke function step’s configured parameters:


and this is my function parameters:


any thoughts appreciated

I’ve seen it before where it gets confused when you add new stuff.
Recycle your app pool. That’s helped us.

We are hosted by epicor, do you know how we would do the App Pool Recycle ?


Oof. Cloud.
Um, I think you have to message support?

yes, they happily rest the application pool, sadly it didn’t help :frowning:

@Banderson did you do anything else to make Epicor happy with your function signature change?

No, it was a recycle, then make sure to get out of epicor and back in again.

I have had problems with the widget in the past, and just coded it because of that.

Yeah, I did exit epicor and restart also, didn’t help

Thought for sure the app pool thing was it

btw, to be clear my function is not a widget, just code

I meant the widget to call the function.

I’ve had issues with this as well. I fixed it somehow, but I can’t remember how. I think maybe exporting the BPM, delete it, and re-import it?

It was when 700 first came out, which was 2 years and 1 job ago…

Please show the code from the method directive where you are calling the function.

1 Like

Kevin, I don’t understand what you mean, “code from the method directive”,
my method directive has no code it is just using an “Invoke Function” step in the BPM
looks like this:


You didn’t mean the actual code in the function did you ?

I believe he was mistaken.

I have already tried deleting my BPM and recreated it (it’s small)…didn’t help

@datadaddy , love that name, can you specify the out param just for fun?

Maybe set checkbox to dump source code and ask SaaS support to send it to you?

(datadaddy is from 20 years ago when I was doing data migration for Peoplesoft go-lives)

I’m somewhat new to all this Epicor stuff, when you say “specify the output param”,
I’m not sure what that means, it’s not really used and comes back as null,
but from examples I was following to invoke services using rest API it appeared one output for the result is needed.

(so since it’s on my signature for my function, it shows up automatically in the BPM step to configure the function)

Thanks for that idea Olga, I’m a newbie and hadn’t thought of that

Create an output parameter here, click the drop down and choose, create new parameter.

I had previously tried that :thinking:

1 Like