Method Directive not working

Help Please!

Why is this not working to create a warning when these parts are shipped?

Your last one is only looking at “added” not “changed” Does it make a difference if you change that?

What is this on? CustShip.Update?

I changed them all to changed and it worked, then it didn’t again :frowning:

It’s on the CustShip.UpdateMaster. Should I move it?

Just checking, might be relevant.

Could you not just use Number of rows in the designed 'query' is more or equal to 1

Put your constraints in the query? If true then raise your message?


:notebook: Forgot “” on wrapped around BOB

Changed row will cover added, updated :slight_smile:

That didn’t work either…

I tried this too!

I just took a look at your original screen capture. I couldn’t tell if the closing parentheses is there on your condition. It probably is, just grabbing at straws!

They are! This should work, right? it does sometimes and sometimes not… I don’t understand.


We’ve just did an update, so I’m wondering if it has something to do with that!
I’ve created an EpicCare case

Write out the logic you want in English here.

If the customer ID is 5011 and the part number is “10006351” or “10005982” then show me a message

Are you wanting to warn the user before the data hits the server or after?

customerCustID field changed row is equal to 5011
and ( Partnum field changed row is equal to 10006351

or Partnum field changed row is equal to 10005982 )

which is what your picture shows already, so :thinking:

I think you need to pull those conditions off and verify your data with some simple messageboxes.

Since Epicor is problematic sometimes and this is a fairly simple BPM, I personally would delete it and recreate it from scratch and see what happens. I have had queries, dashboards, and BPMs sometimes do dumb things after I’ve manipulated them numerous times and occasionally just deleting and recreating fixes it. Especially since you pointed out it worked once and then didn’t.

Thanks! That worked :slight_smile:

1 Like