Mobile CRM - Performance Issues


I am currently testing Mobile CRM with the help of a salesperson, who is trying to use the package on a day to day basis.

Whilst the module works, we are encountering some performance issues.

Has anyone got any tips on improving performance (e.g. custom indexes etc)?



We are testing it now with a few folks, but not really seeing any performance problems, except when on a few older phones - and particularly iphone 4/5s - it’s really bad in the iphone 4.

The BAQs seem to be working rather well, and synch speed is mostly a factor of cellular signal strength. Our guys are out in the boonies a lot, but once the initial synch is done, individual transactions are not bad.

It also works via updateable BAQs, so all Method and Data Directives/BPMs you have in place must fire as part of the business logic, so if you have some of those, they might be slowing the transaction speed down.

What are you seeing?

Hi Mike,

Thanks for taking the time to respond.

These are the specific issues that have been raised.

Unfortunately, the seem quite random, so it is a nightmare to troubleshoot.

•A bit slow – ‘Geocoding’ kept coming up in the bottom left

•Internal server error occurs often

•Unknown exception in erpBaqService during ‘Edit to do’.

•Chinese writing kept popping up randomly

It may well be the device, as it is been used on a fairly old ipad.

Best Regards,


•A bit slow – ‘Geocoding’ kept coming up in the bottom left
•Internal server error occurs often
•Unknown exception in erpBaqService during ‘Edit to do’.
•Chinese writing kept popping up randomly

  • Geocoding is a big gripe. The device does the work, NOT the server. Each device will have to geocode for itself. We have a ticket in with DEV to remedy that one for sure.
  • We get the internal error once in a while, but we’re doing a lot of testing of different functions when it happens.
  • We’ve not really gotten to Tasks/To-Do items yet…
  • Chinese writing - got nothing on that…:slight_smile:

And an Apple device might be a big part of the problem. Honestly. The devs we’ve been working with for a year now have always admitted to a bug with early apple OS’s. Get yourself an old android tablet and see what happens.

Thanks Mike - I will update the post if I get any progress with these

Out of curiosity how long does Geocoding typically take? I have been getting the same thing and just assuming the app has frozen / crashed.

took a few hours for us with 5500 customers…

Hey @aclements any chance you have gotten anywhere with these things? I stopped my testing for a bit because I couldn’t get it past Geocoding. Just curious if you have had luck with the asian characters, performance, etc?

Nothing yet - I’m afraid. The asian characters is very repeatable - i.e. just press down on your tablet and get the ‘select all’ dialogue and it is in Chinese.

Suppot came back with the need for repeatable issues, which I understand, but not always easy with performance issues that seem very ad hoc.

The main user is on the road with it at the moment, so this will be the ultimate road test.

I’ll update when I know more.

I’d like to invite some others to this thread as well since we’ve been having other conversations Regarding the Mobile App. @Graeme_Fraser @Mark_Wonsil @efalkowski

As it sits currently, We are at a stand-still since we cannot get the Mobile CRM to even launch on ANY Android

I ran through the cleanup script and redeployed the BAQs fresh and that fixed our issue with the app freezing when loading. As far as the Asian characters go this is the support response today (PRB0208745):

Problem description:
In different forms (date fields) of Epicor Mobile CRM appears the initialize letters of year, month and day with Chinese/Japanese language.
The forms affected are the following:
-Opportunities form - Add Opportunity/Quote (Expected Close field).
-Activities form - Logs: Add Incoming Call, Add Outgoing Call and Add Email In (Start Date Time field).
-Activities form - Tasks: To Do (Due Date Time) and Appointment (Start Date Time-End Date Time).
-Orders form - Add Order (Order date and Need by fields).
-Give Us Feedback (Attach field).

Expected behavior:
Date fields should be appear according of language configuration.

This cosmetic issue appears with Spanish/English language setup.

Development is currently working on getting this fix on the next version.

Epicor has duplicated the same problem with Android devices and the issue is being handled by the DEV group

@efalkowski - Well, they ain’t lying to you. I just got an email form the DEV group that says:

“We are currently working on a critical Android bug, which has been keeping us busy, so sorry for the delay on answering you.”

Anyway, looks like your bug is taking precedence over the UD fields problem. :slight_smile: But they say the next version is still on time for the week of the 19th.

Thanks for the update… Yeah, we need both to work for sure!

Also found that the UD field problem is in Quotes, but not in Customers. Opened a ticket with Support and got it straight to DEV.

Have not tried any other screen - have you?

PRB0210265 - Custom BAQ for Quotes is not displaying UD field on Details but it is on edit

Just got an email from DEV saying this is fixed in v2.0. The Jira notes are non-existent, but thought I’d drop it out here for everyone.