MRP does not create job

We need some help understanding why MRP is not suggesting a job for one of our open orders. The order record is created in the Job Detail table, but there is no MRP job, nor are the parts in Suggested POs. This order is a test case to try and get handle on which revision MRP picks, so the test data is a little weird, but not completely unrealistic.

MRP Parameters:

Run Regenerative
Cutoff Date: End of month + 3 months (dynamic is checked)
Schedule Start Date: today (dynamic is checked)
Run Finite Scheduling… UNCHECKED
Ignore Constrained Materials: CHECKED
Allow Historical Dates: CHECKED
Use Production Preparation Buffer : CHECKED
Sort Level 0 MRP Jobs by Date: INACTIVE
Get Details from Quote: UNCHECKED
Run Multi-Level Pegging: CHECKED
Include Contract PO Parts: UNCHECKED
Run Generate Purchase Sched: INACTIVE

The order is for one TL-021. Order Date 9/1/18. Need By: 10/5/18. Ship by: 10/5/18. None in stock.
TL-021 is composed of SUB-021-1 and SUB-022-1.

SUB-021-1 has four approved revisions with the following effective dates
A: 9/1/18
B: 9/19/18
C: 10/3/18
D: 10/11/18
SUB-021-1 has one operation; Production standard is 80 Hours/Piece

What we were hoping to see is which rev of SUB-021-1 was pulled (by MRP) for the order, so we knew what date comparison was being done (This issue arose because our production team noticed that on certain orders, MRP was creating jobs for an older revision).

So if MRP compares Revision Effective date with Order Date, it would pull Rev A
So if MRP compares Revision Effective date with Ship By Date, it would pull Rev C (because it’s later than B, but still less than Ship By)
So if MRP compares Revision Effective date with Current System Date, it would pull Rev D

We were not expecting that no jobs would be created.

Can anyone either explain how this works or point me to an explanation.


Can I assume you’re working in a test system and that you can play around with different options, run/re-run MRP whenever you want?

A few other questions…
What does time phase look like for your part(s)?

Can you find your parts listed in the Planning Workbench?

Have you tried MRP without dynamic dates?
Tried specify higher logging level and checking logs for any errors or references to your part(s)?

1 Like


Sorry I think there is something worng with your logic here.

This is how I have always understood MRP to work. Obviously the gurus out there will correct me!

Depending how you have MRP run (daily, weekly etc), the system will look at your SO and check to see what rev you used there, then use that rev to create the job. By your dates, if rev A was at the line level and it was an approved rev with an actual MOM tied to it, it would use that one regardless of the effective date.

If you did NOT put a rev on the SO, the system will pic the latest rev that is approved AND has a MOM attached to it.

I keep referring to a MOM attached. This is always the reason why a job is not created. I can have a rev against the part that is approved, but if I never created the details of the method, the system has nothing to create and you get no job.

So check that your rev actually has a method. If it does then I am at a loss.


1 Like

Thanks. Will check it out.

I agree with @manasa6 and @bordway
A few questions about the part:
For TL-021’s Order Rel Plant, how are the planning parameters setup?
For instance, Process MRP should be enabled.
Is there a valid and approved revision for TL-021.
If MRP is enabled but a revision cannot be found, you will find the demand in the Planning Workbench, if it’s not there, you may try running the MRP recalc needed process and then run MRP again.
Like @bordway said, getting those Log files is key. And if you run MRP just on the TL-021 part, it will make it easier to read.

Two very quick checks are

  • the log file may give you the error.

  • Alternatively, have you tried creating the job via quick job entry - this can identify issues with creating the job.

And then answer is… because my order was old (had a due date before the system date). Epicor Support was very helpful. I have attached my notes from the call in case they are useful to anyone else.Notes from call 20181029 0826.pdf (425.1 KB)

1 Like