Open Form and Pass Data with Button Click

Hey everyone,

What is the best way to open other forms/applications in Kinetic and pass data using a button click?

I’m trying to recreate a classic customization we have so that our users can start using the Kinetic screens. In the classic customization I use ProcessCaller.LaunchForm(oTrans, “XXXX”, lfo); in an onclick event.

I found an “app-open” item in the events toolbox, but I have no idea what to put in the parameters (or if that’s even the correct way to use it).

Thanks,
Kevin

App-Open is the correct widget.

Here’s a screen cap of the parameters it’s looking for.
*If you uncheck “Slide Out”, it will open in a new tab instead of the slide out panel.

Just as a note–you don’t need to use TransView for your LFO binding. That just happened to be what I bound my test TextBox to.

1 Like

Something kind of cool (not sure if the old did this), but it automatically called GetNewPart if it couldn’t find an existing part.

Thanks Aaron!
Just curious, did you just figure out what was required yourself or is there some document you found that explains the various widgets?

I was able to use your example to open some standard apps, but unfortunately when I tried to use it to open an app we created for a BAQ report (Ice.UIRpt.UD_AR_INVOICE), it gave me the below error. Have you run into it before?

“The assembly ‘C:\ProgramData\Epicor\centralusdtapp02.epicorsaas.com-443\4.1.100.0\19707\shared\CustomDLLs\Ice.UIRpt.UD_AR_INVOICE.dll’ could not be found.”

Little bit of both. I used Epicor as an example. Inside of the MetaUI folder, they have all of the JSON for the stuff they already converted to Kinetic. I opened up the SalesOrderEntry one and looked in the events folder. I opened up the JSON called OpenView.events.jsonc because it sounded like it could contain the info I wanted. Then I searched for “app-open” and played with the params based on what they set.

At what point did you receive this error? I wired mine up to a BAQ Report we have and the slide out came up fine.

Are you able to preview the report okay through the smart client?

Interesting, I’m not sure we have the same level of access as you since we are a cloud customer. We currently can’t even access Kinetic forms from a web browser, we have to use the Epicor client.

For the error, below is the screenshot for how I configured the on click event. I didn’t even try the lfo yet, I was just trying to see if I could just open the form. I’m able to preview the BAQ report app in Kinetic just fine, it just won’t open it from the button click. If I leave the “Slide Out” flag checked, then nothing happens when I click the button. If I uncheck the flag, then I get the error when I click it.

I think I’ll create a support ticket for my error message since the button works fine if I try to open a standard Kinetic app.

Try these changes:

Ohh yes, I forgot. I tried a few ways and that screenshot was only my last attempt. I tried it with “Ice.UIRpt.UD_AR_INVOICE” yesterday. I also tried it with no “Page” and "Details.

Here is what my original setup was.

This message is tickling at the back of my head. What’s odd to me is it’s trying to locate something client side, but the stuff we wire up in App Studio lives server side…
Do you have another working BAQ Report you could try it against?

I tried to recreate your error, but was not able to get it.

This is the closest I got which happened prior to me previewing the report in Kinetic which is what generated the MetaUI files on the server.

Ice.Common.EpicorServerException: Processing Error : No file found C:\inetpub\wwwroot\SANDBOX11\Server\\Apps\MetaUI\Ice.UIRpt.HighProfile\layout.json 

Yeah, it is odd. That is kind of why I suspect it’s something cloud related.
I did try with another BAQ Report we have and got the same error. So it looks like it is something particular with BAQ Report applications. I have a case open so hopefully support will be able to tell me what is going wrong.

1 Like

Lemme know what you find out. I’m very curious!

Paging Mr. Cloud @Mark_Wonsil !

Do you have a Kinetic environment you can try opening a BAQ Report form from App Studio with? I’m curious to see if you get the same results as Kevin.

Sorry, I do not. We’re Azure here not SaaS. Bruce (@LarsonSolutions) works with SaaS customers, so he may be able to prove this one out.

Guess you’re not as SaaSy as I thought.
Shame. :wink:

1 Like

I missed this note -
I am not that technical yet, but looking to learn a few things with AppStudio.

Yes, I have worked and broken a few rules around SaaS, but not on the technical side yet.
Hope this has been figured out.

1 Like