Operation details on PO Entry / PO Tracker

Hey so what is a good way to get the Operation Description to show on PO Entry / Tracker for Subcontract lines?

I see the OpCode field is available by default, but the OpDesc field is not. I can’t mimic the combo control from eg JobTracker (OpCodeOpDesc isn’t available in the form).

So should I use a BAQCombo? Or Make a BPM to load it into BPMCallContext? Or add UD field to POSubContractLine (or equivalent), and populate it with a BPM?

Don’t really love any of those options… wondering if there is a better way. Thanks!

The dropdown Epicor has there already has that info. If you look at the properties you can see it’s doing a search, but it displays the OprSeq field:

Easiest way is just copy & paste the dropdown into a new one and then change the display option to show the op description:

Note that the search in the field is dynamic and it is linked to the selection you make in the Buy For section. When you copy the field, make sure you copy the one with the operations.

Oh good idea thanks. Except that when I copied the field, looks like something got corrupted on the built in field :frowning:
Now I see this

Update - Somehow my client install got hosed. Even the base form cmbOpr properties loaded up as blank. Opened fine on a different client. Clear client cache surprisingly didn’t fix. Had to re-copy the install files to my machine.. Clear client cache and restart Epicor and Explorer fixed.

I tried to get your method working for a couple hours, but it is not working for me…

  • Even changing the native cmbOpr control to have the DisplayMember as OpCodeOpDesc did not display the description, it stays displaying the jobseq.
  • I tried setting the new combo to use the BO.OpMaster method, where OpDesc is also available, but it still only showed the OpCode.
  • Copying the native control caused all kinds of weirdness… eg the native control disappearing from the tree.

I’m assuming all those work for you? Do you see anything I am doing wrong??

I did get the BAQ combo working.

Yeah, it did something weird the first time and I had to delete the customization and try again. I didn’t touch the original dropdown though, all the changes I did were in the copy. Also, you can just create a new dropdown from scratch and then set the properties yourself. Glad to hear it’s sorted.