Operation Scheduling

Hi every one,
the nearest topic i found related to my issue is this:
Job won’t schedule some operations
i have checked every stated factor with no luck,

  1. Job operations have got est. time (Setup or Production).
  2. no labor transactions linked to these operations.
    3.still open.
  3. no completed qty.
  4. only one resource group attached to it.
  5. resource group has active calendar.
  6. priority and scheduling factor is right.
    8.run individual infinite forward scheduling task.
  7. run global infinite scheduling process.
  8. Allow scheduling before today is [Unticked]

operation scheduled start and due date are wrong, what i am missing here? has any one come across this issue guys?

What are you trying to do? Reschedule this job? Or are you trying to run the global scheduling and it crashes? Could you please post part of the log if possible? Is the global scheduler running with no errors and just missing this one?


I don’t know if this matters or not and maybe you have the format set correct on the back end. I noticed on your Job Tracker that the dates are formatted differently. Are they set that way or did someone make a mistake?

i tried both, but for this particular job i have (forward) rescheduled many times after checking all the listed factors, and still have non-completed operation scheduled to start on the past.

thanks Kim,
no it is set using this format in purpose, i know that when you call dates field in SQL, it will appear differently, but as a UK company this is the date format that we want to see on all UI

1 Like

Was there a log generated?

no, i will run it again with log and whatever filter i can apply to narrow it down and let everyone knows

i could not find any details about operation scheduling on the log ( i have selected process and scheduling option to show every thing)…please correct me if i am missing anything

OK folks, finally i’ve cracked the problem, a guy in EUG asked a question about [Global Reschedule Started Operation] check box, if it is ticked? i answered him it is not and it -meant to be- set that way, because as per my understanding it is not relevant to this case, and again i am referring to Epicor manual which is -not clear at all- in my opinion (let me put it this poilit way)

however, i have ticked it then done many tests including adjust some job operations to be completed / and reopen on started and non started, just to see what other possible effect that might happen, and i found the following, -what i think it has been missed in this definition of this check box- :

  1. If this check box [UnTicked], Epicor Infinite forward Scheduling will ignore scheduling any Uncompleted non started operation -Only- if this operation has a previous open started operation, and this is what caused all successor operations to have wrong scheduled start date.

  2. if this check box [Ticked], Epicor Infinite forward scheduling will deal with completed operation (closed) by given it the (entered forward scheduling start date - 1) and zero load time, thereby the next open operation will scheduled to start in the correct start date.

  3. if this check box [Ticked], Epicor Infinite forward scheduling will deal with Uncompleted started and/or non started (open) operation by giving it the exact entered forward scheduling start date and calculating the relevant load time based on complete percentage% which is based on completed qty, thereby all successor operations will have the right scheduled start date.

Thanks you all for your help and valued contribution, i think that this topic thread now is a good operation scheduling reference for everyone.

1 Like