Pass information from NC to DMR

My inspectors would like to have people on the floor fill in information on the NonConformance and have it show up on the DMR. I added a field NonConf.Character01 to the NC header but that field is not an option on the DMR header to show the info. I added a field and set the LIKE property to the field in the DMR head but the information does not show through. Any ideas how to do this?

Hi Melissa,
In the past, the way I’ve done it, is in the Customization Tools Dialog you can click on Tools - Data Tools and add a New Custom View (Foreign Key View) and connect the DMRHead table to the NonConf table through the NonConfID Column and Adapter:

Then when you go into the EpiBinding list you should see your FKV and the fields associated with that table:

I hope that helps! Maybe there is a better way to do this but this is what has worked for us. :wink:


I don’t know exactly what you are looking for but, we found that it was hard to tie the DMR back to the Non Conformance.

I wrote a BPM when the NC is dispositioned as failed.

Here are some of the fields that are being written to the DMR record.

Assign ttDMRActn.Number01 = NonConf.PONum.
Assign ttDMRActn.Number02 = NonConf.POLine.
Assign ttDMRActn.Number03 = NonConf.PORelNum.
Assign ttDMRActn.Number04 = NonConf.TranID.
Assign ttDMRActn.Number05 = NonConf.VendorNum.
Assign ttDMRActn.ShortChar04 = NonConf.PartNum.

Thanks for the suggestion. Unfortunately when I try this I get a drop down in the column name and NonConfID is not an option. I don’t know why I can’t type in that field.

You are welcome, I’m just sorry it’s not working for you! :confused:

Just to see if a little more detail helps…I’m in the DMR Processing Form.

And in the Custom Data Dialog window, I selected DMRHead in the Parent View Name dropdown list. Foreign Key View gets automatically populated in the View Type field.

Then it gives me the Column Name list dropdown with the NonConfID option:

Could you post a print screen of the list you are seeing? :slight_smile:

That is so strange. I have the exact same list except for NonConfID…

I am running 9.05.603, should I ask Epicor about that?


Did you make sure NV: DMRHead was selected in the left pane before clicking New Custom View? These options look like DMRActnOpr was selected in the left pane.

1 Like

Hum…that is very strange indeed. I just tried highlighting each item in the left Custom Views pane before pressing the New Custom View button in my .702 environment and they all gave me the NonConfID BUT what @danbedwards suggested is definitely worth a try (making sure you click and highlight the DMRHead in the left pane before you click New Custom View button) because I swear I have seen it behave that way before and not give you the same drop-down list depending on what you select/highlight in that left pane.

.603 eh? Maybe it is a version difference? I’m working in .702… and just out of curiosity are you working with the Base form or is there already a Customization on this form?

I know there are other ways to do this like @Cathy suggested, I was just hoping that this would be the quickest and easiest way for you to slap that NonConf.Character01 field on there… :slight_smile:

1 Like