PO Entry Currency Error

Entering a PO and getting a currency error on one part. Checked the part and supplier price list and all looks good. Error is:
Currency Rule not found for Rate Type: 1 From Currency: $ To Currency: USD

Any help would be greatly appreciated. There are 6 other lines on the PO that worked fine. Just upgraded from 10.0.700.4 to

I hope you don’t have a Currency actually named $

The Question I have is why is trying to go from $ to USD. Do you have both USD and $ as a currency?

You should be using stuff like:

  • USD
  • CAD
  • MXN

Not trying to go from $ to USD. Everything is in USD currency.

Do you do any inter-company trading?

I have seen this error previously only difference for me it was from BLANK to USD. Yours talks about rates.

It was some bad setup in the Customer Record for Inter-Company Trading for us atleast, so you might want to check the Supplier/Internal Customer related to the PO. Or check Currency Settings, somewhere that $ exist. Probably a drop-down somewhere allowing you to select the Suppliers/Customers Currency and someone keyed in $ make sure your Price Lists, Supplier, Part, PO all have USD and not $ forced into a dropdown or so via keyboard

Really weird I don’t see a $ anywhere. We have six other lines on this PO for and this is the only part that has the issue.

Do you use Inter-Company Trading? or Multi-Company?

I found the $. It was in the vendpart table. Changed it to USD and everything worked. Only visible at the table level.

1 Like