PO tracker menu opens PO Entry Form

We are on 10.1.600.4 and have an issue where PO tracker open PO entry form from menu and when you do open with. Anyone else having this issue?

Kristine Fierce
Business Systems Analyst
Ag Leader Technology

Have you tried going into the Menu Maintenance and checking the PO tracker menu indeed is set to launch the PO tracking program?

There is supposedly a known issue with this, PO tracker actually use Erp.UI,POEntry.dll and Epicor must have it programmed to know to open tracker version. Support confirmed this for 10.1.600.4
I will send our DB to the to get it fixed

Hi Kristine,

I noticed this when we updated to 10.1.600 as well. All po tracker forms that we manually added to the menu no longer worked. Looking in the Ice.Menu table I noticed that the POTracker dll is no longer used rather it’s an argument to the POEntry dll now. -formName POTrackerForm needs to be added to the menu item in order to get it to open POTracker. If you are able to query the database you cane use the bellow select to see which records need to be updated. Alternatively you could also use a BAQ.

SELECT * FROM Ice.Menu WHERE Program LIKE '%POEntry%'

Thank you @Jeremy_Westbrook That took care of the issue.

I see the arguements in the BAQ, do you have to make a UBaq to add them? Or is there something in the menu maintenance that I am missing?

I did a direct SQL update. At the time I didn’t see any other way of adding it in there. UBAQ would probably have been a better route.

Alright, I’ll give that a try. Thanks. (sure is frustrating when they make a new option/requirement that you have to use a backdoor to use.)

Hi Guys…

I am going to refresh this thread if possible.
I remember needing to do this trick (mentioned above) in the menu table from our last upgrade to 10.1.400.
This cured my woes back then.

Now I am trying to validate 10.2.300 in a Development Environment and I have slightly different issue.
With the client install of 10.2.300 , Erp.UI.POTracker.dll does not exist in the client directory.
Nor does it exists on the server.
So I can update the menu table like we did for 10.1.400, but things will not launch b/c there is no program to run.in 10.2.300.

Message: Cannot access this menu item: Purchase Order Tracker
Inner Exception Message: The assembly ‘C:\ProgramData\Epicor\ma1win12epdev-808\3.2.300.0\ROGERS\shared\CustomDLLs\Erp.UI.POTracker.dll’ could not be found.

Anyone confirm or deny similar?
I will open a ticket with them.

I tried to dump the Erp.UI.POTracker.dll the 10.1.400 directory into the new install of 10.2.300, but the menu threw a version message (as expected… but I couldn’t help but try)… This is what a DEV server is for,

Thanks,
JM

1 Like

The trackers don’t use a different DLL. They use the same one as POEntry with different arguments to specify which for it’s using. the Tracker form needs -formName POTrackerForm in the arguments field.

I attached the UBaq to go and set the arguments.

MenuCustomizationSet.baq (23.0 KB)

2 Likes

Thanks Banderson,

I do see the form -formName argument when I query the Ice.Menu table and see how that works.

Do I need to rebuild my form customizations that we had for POTracker?
How do I get the POTracker Customizations to launch from the menu?

-JM

1 Like

In menu maintenance, you will set the customization there. All that does is add another part to the to the argument starting with -c. There can be more than one argument.

1 Like

Thanks… got it now.
Looks like I will need to duplicate the cosmetics from the old customizations b/c they were tied to the old dll.
I do have the menu pulling a customization now though… thanks for the BAQ.

-JM

1 Like

Thanks to all for your prompt and very helpful suggestions :slight_smile:
I created an UBAQ on the Menu table, making Menu.Arguments updateable.
I then updated the Engineering Workbench Menu Arguments to "-c " + “my customisation name”
That seems to have worked!