Print Preview not working

I’ve restart the task agent to no avail. I also took a look on the server and I see the XML file being reported under the username, and in System Monitor it shows ? with no errors. The failure mode is the print preview never pops up(no errors/warnings).

How can one troubleshoot further?

Does it matter which report?

Try it from a different client. I’ve seen things go wonky and other peoples reports sho up on the wrong client machine

If you open the system monitor, does it then print? I’m troubleshooting a similar issue where as a security manager, when I open the system monitor, those reports printed by another user open in my session instead. My issue seem to be that even if I check the configuration check box to ‘Start System Monitor’ as enabled, it doesn’t retain it’s saved setting and the system monitor icon never shows up in the tray icon section.

Great question, yes from system monitor it works flawlessy.

In regards to is it a certain report - no it seems to be any report. Also, it’s intermittent in that yesterday it worked OK for me and today it’s not working for me, and yesterday the people it wasn’t working for today report it works OK. We’re able to work around the problem by opening system monitor, but it would sure be nice if this worked…

Does it work correctly if you run those reports as a security manager account?

No, I’m a security manage and experiencing issues.

Yeah, it’s happening to me too using a security manager account. Seems odd that this checkbox isn’t saving or starting the system monitor correctly.

Geez, I just looked in System Monitor again and there are errors… History Tasks shows completed with no errors, but the report tab has errors. Can anyone help me to understand what these errors mean, they seem to be truncated so cant’ read the entire error…

As far as the system monitor goes, when we initially deployed 10.2.500 (I think) it did not automatically set the flag in the config file to start the system monitor when Epicor opened. I have since corrected the config files that get distributed on new installations, but I also found there is a utility distributed on installation called ConfigEditor.exe in the Epicor Client directory that allows you to modify the config file. When you run it, you select the configuration you want to update, then go to the User tab and make sure the Start System Monitor box is checked.
This updates the config file and then the system monitor will always start on opening Epicor.