Printer Defaults Resetting only in Epicor

Has anyone run into and solved this? We have several users who consistently have to reset a label size on their label printer or set a page size to A4 (or away from A4) on their copier/printer when printing a particular document out of Epicor. We can change the defaults on the driver on the print server and in Windows Devices & Printers settings on the client until we’re blue in the face, it’s like Epicor has it’s own ideas about the default printer settings should be.

Epicor utilizes the Report Style which ties to the SSRS report layout. After that the printer device driver settings for the printer should match the SSRS report layout.

What version of Epicor are you on? We’ve been having weird issues since going with 10.1.600

We are on Epicor 10.1.500.14

We are on 10.1.400.16.

Make sure you have up-to-date device driver installed for the target printer on the workstation and SSRS server or Report Server. This should cover printing from the client or server.

Odd, we never had problems with the 10.1.500 series.

This could be related to Windows updates?

Is this the Cash Receipts Edit List? If so, I reported a bug to Epicor
which they have refused to acknowledge. The Paper size on the SSRS report
they distribute is incorrect. The solution is to go open the base report
in Report Builder and right click the background, open the properties, and
change the paper size for the report (It shows as custom, which means the
user has to change it every time they run the report)

Every time you upgrade you will have to do this. I will probably report it
again as a bug and see if I can get someone to listen to me about it this


I think you are on to something here @Paul_Millsaps - thanks! I was able to fix at least one of the reports by removing all printer / page size associations from the Crystal report file.

I’m still waiting, but hopeful, to see if it fixed the issue with AP Check printing.

have to reset a label size on their label printer or set a page size to A4 (or away from)

Sounds like you’ve already solved this. So just a note on similar issue I ran into with label sizes on a Zebra printer.
In my case, I discovered separate paper sizes could exist in the Windows printer setup - one for printing defaults and another for printing preferences. Which of the sheets display would depend on where I started from within the printer setup control. Once I knew to check/match the paper size in both locations, my label size/printing issues went away.