Process ID unknown?

I've seen a couple of these, unfortunately I've never been able to find the
cause. I've always just worked around it, as I've only seen it happen with
2-3 methods.

On a more useful note, try attaching to the notify event rather than the
method call. Note, you may need to move your update code from the BPM to the
customization if you use this method. I believe the notify usually fires
before/concurrently with post-processing directives.

Also, if you run your BPM pre-processing (not sure if that's viable for you)
the UI should stay current.

On Tue, Aug 16, 2011 at 2:14 PM, tchristie1 <tchristie@...>wrote:

> **
>
>
> I am writing a customization on the Mass Issue to Mfg screen in Epicor
> 9.05.604A. While a trace indicates that the method I am interested in gets
> called, I cannot get a customization to see it (using the wizard to add an
> after adapter event). I created a BPM that triggers when the method is used
> and it triggers fine but the processID is reports is: "Unknown." Any ideas
> as to why I cannot seem to get a after-adapter event to trigger even though
> the trace indicates it happens and a BPM will run off it as well.
>
> The method is MassIssueToMfg.OnChangeJobNum.
>
> I am attempting to pull some notes from custom fields on Sales Orders
> attached to the job through demand links. I can get a BPM to run, collect
> the data, and store it into a BPMclientcontextdata field but I need to
> refresh the gui after the BPM runs. I have done this before by adding a
> little bit of code in the form to refresh if the method has just been run. I
> just can't seem to get the customization to run the after-adapter method.
>
> Has anyone had a similar issue?
>
>
>



--
*Waffqle Driggers*
*High End Dev, System Design, Profit Drinking
*
*:: 904.962.2887*
*:: waffqle@...*
*:: NO FAXES*

*

*


[Non-text portions of this message have been removed]
I am writing a customization on the Mass Issue to Mfg screen in Epicor 9.05.604A. While a trace indicates that the method I am interested in gets called, I cannot get a customization to see it (using the wizard to add an after adapter event). I created a BPM that triggers when the method is used and it triggers fine but the processID is reports is: "Unknown." Any ideas as to why I cannot seem to get a after-adapter event to trigger even though the trace indicates it happens and a BPM will run off it as well.

The method is MassIssueToMfg.OnChangeJobNum.

I am attempting to pull some notes from custom fields on Sales Orders attached to the job through demand links. I can get a BPM to run, collect the data, and store it into a BPMclientcontextdata field but I need to refresh the gui after the BPM runs. I have done this before by adding a little bit of code in the form to refresh if the method has just been run. I just can't seem to get the customization to run the after-adapter method.

Has anyone had a similar issue?