Quickship Upgrade from 4x to 5x

Curious if anyone else has made that exchange and found themselves faced with either of these errors.


We just went Live this weekend. I received the “admin is already in role ‘ISC_User’” error and what happened with us is the Admin account was deleted somewhere along the line in the upgrade. I used SQL Import Export Wizard to transfer that one account to the UserLogin table and that resolved my issue.

I did not run into the first error you’re getting

1 Like

We never had an admin account just InsiteAdmin brought up from 3.X. We keep getting random object not an instance and sql errors trying to use it.

We also have the InsiteAdmin account brought from manifest. When I go into setup users within QuickShip it looks like a System account. Im not able to edit anything within the User Setup area like I am with other users.

Interesting yeah admin is nowhere to be found in our system, which makes sense because they have you overwrite the QuickShip database with your Manifest Database, but then how is this upgrade ever supposed to work properly?

I just got off a support call with QuickShip and he said the Admin account comes with the install and its a system login and needs to be there. I asked a few prodding questions about how ours got lost but not much information back on that.

I don’t know that it helps much on the “how” but if you’re able to get that admin account in there, I believe that will resolve it. Maybe install on a test server to get the seed data in there and then export over the admin account from dbo.UserLogin… That essentially the route I went

I’ll give that a go. Just went live on 600.3 so dealing with ERP yet before I can bounce to QuickShip. I will file a case with them the upgrade process is poorly documented regardless. Thanks for the verification though! Admin does come in the seed data when you install QuickShip but when you are instructed to overwrite the seed database with your v3 or v4 database it totally makes sense Admin go poof.

Yeah that’s exactly what I’m seeing as well. I’ll update again if I find out any more information as we work out the bugs

I have a webex at 1:30 with them today i’ll report back what I come up with. Going to see if I can squeak in the SQL errors that keep cropping up too, but only put the ticket in for the Admin issue at the moment.

If you upgrade to QuickShip 5.2 and do not have the Admin user do the following

  1. Log into QuickShip with your InsiteAdmin user
  2. Go to Setup from the home screen
  3. Go to Users from the setup screen
  4. Click the plus in the top right to add a user
  5. Add the admin user manually with the following information
    a. Name: Admin
    b. User Name: Admin
    c. Password: password123 (and confirm password)
    d. Email Address: ship_support@epicor.com
    e. Select Role: ISC_ADMIN
    f. Password Question: What were the last four digits of your childhood telephone number
    g. Password Answer: 1234
  6. Click Add
  7. At this point you should have a non-editable Admin user and things should start working smoothly.

This appears to be the only diversion from the upgrade guide and is not the expected behaviour. Development is aware and is working on it for future version(s).

2 Likes

I’ve stumbled across this very same issue doing our upgrade testing. When I try to add the Admin user, I get an Object reference not set to an instance of an object error. No further detail. I have tried chrome and IE and both yield the same result.

It worked for me when the information in my previous post is entered exactly as listed.

I believe I’m entering it exactly as you had listed. Out of curiosity, what version of 5.2 were you using? I’m using 5.2.1.11153.

5.2.1.11153 samesies. Apparently a 5.3 is available now? That was what I was told this AM on a case about another issue in QuickShip

Yup, I just checked epicweb and indeed 5.3 is there so I will try again using the newer version. Thank you for the tip.

Interesting development. The full installation instructions for 5.3 actually has an entry for the Admin User that is missing. Even more interesting, the actual code version 5.3.0.11835 does not have the field the instructions says it has so it installs just like 5.2 did and then requires manually creating the Admin user.

I found my issue was the browser.

I’m done for the day.

I’m going to get a beer!