Resource Group BPM to set LaborEqBurden True

I’m not having much luck with BPM’s today. One other simple request from our finance dept was to set the LaborEqBurden to true on new resource groups.

I activated trace, Clicked New Resource Group, and the log showed that Epicor called the GetNewResourceGroup method and brought it in with Split Burden = True in the dataset. I created a simple Pre BPM to set the field, but it doesn’t seem to do anything. I added a ShowMessage box right after the start, but it never fires.

I even tried setting Split Burden to False with another Set Field, but no change.

What am I missing? Seems so simple… Frustrating to leave work on Friday on this note. :stuck_out_tongue:

Thanks for the help, guys. Have a good weekend!



    <localTime>10/5/2018 16:43:50:7885021 PM</localTime>
      <parameter name="ds" type="ResourceGroupDataSet">
        <ResourceGroupDataSet xmlns="" />
      <returnParameter name="ds" type="ResourceGroupTableset">
        <ResourceGroupDataSet xmlns="">

I dont think that method gets an “Added” row, I think it produces one.

Chris - Thank you. I tried to dumb it down even more by attaching a ‘show message’ to the method with nothing else, but no love from Epicor. I create a new resource group, but never get the pop-up message. I tried it as a POST as well…

This makes 0 sense. You see ResourceGroup.GetNewResourceGroup in the trace… you should be getting that message. Stupid questions:
Is the directive enabled?
Is it set to Company Independent?
You’ve created a new group since creating the BPM?

Chris - Thanks.

  1. Directive is enabled.
  2. Hmm, let me check that… Scope was by default as Company Specific, but we only have one company, and it’s in the Owner Company box. Let me set it to Company Independent, and see if it changes… No change.
  3. Yes, try a new one every time (i.e. Test4). I click on the “Create New” blank sheet icon, the fields turn from grey to white, I get the nag messages if I forget to enter a dept or warehouses, etc…

Uhh… I was wrong on #1! Embarrassed to share this, but the BPM’s were globally disabled in my test environment by editing the web.config file line:
<customizationSettings disabled="true" intermediateFolder="C:\inetpub\wwwroot\ServerName\Server\BPM">

It didn’t set the fields properly in Pre, but worked in Post.

Thanks for your help, Chris!


1 Like

:smiley: Been there, done that, got the tshirt haha

1 Like