Reusable Combobox on ProdGrup.ProdGrupCombo Not Working

I’m trying to setup a combo box for Prodgroup group. In preview mode it lists the product codes in our system but the returned grid isn’t filtered properly. I added a text box and set it to the same search filter and it displays the correct ProdCode so in-theory should work but doesn’t. In the where list I tried matches and = but none work.

I followed the instructions from Hannah and this thread

Preview Results;

Combobox Settings:


If you don’t have multiple Where Clauses… you can do it outside in BAQ Options:

This one works for me:

Interesting, won’t work in this case as we have a total of eight filters. :expressionless: Could work on another dash I’m uplifting though.

Another thing you can try is to filter the grid by an event using dataview-filter-set.

So your BAQ would run wide open and fully populate the DataView. Then use the event to filter the dataset after the fact.

I used the one above on a SalesRep Combobox tied to TransView.SalesRepFilter

The condition is just to make sure I have a value: '{TransView.SalesRepFilter}' === ''

If FALSE… then I filter the target dataview (“Orders” in my case):

The Filter here can include multiples:
Orders.Calculated_SalesRep1 = '{TransView.SalesRepFilter}' OR Orders.Calculated_SalesRep2 = '{TransView.SalesRepFilter}' OR Orders.Calculated_SalesRep3 = '{TransView.SalesRepFilter}'

The problem I was never able to solve was “clearing” the filter. That was my TRUE side of the condition. I was hoping clearing the combobox would give me a value of ’ ’ … and then the filtered grid would revert back to the full dataview results… but I couldn’t get that to work.

So, the false branch works, but clearing the filter is still a mystery to me.

1 Like

I deleted everything in the Where List and recreated them one at a time then tested the dashboard. Now the filters are working as intended in DevTools. Guess I ran into a bug?

Now to fight the column layout and hidden :dragon: err :beetle:


Thanks I’m keeping this suggestion in my notes!

Go figure! At least its working!