Row has been modified by another user

My users occasionally get this message. We don’t know why, it is not what the message is telling us. We always have to refresh the form. Any ideas what else is causing this?


This is generally due to fields being updated on the backend due to a customization or a BPM. do you have any of those running in this sections of Epicor?

The only BPM i have is the change log.

We have this issue in several places within Epicor (order Entry and Customer Shipment Entry are the biggest impact).
I don’t think it has anything to do with BPM’s or Customizations because we have all of those things turned off in our Test mode and still get the message. Even in Base Mode we will get the message.
We have definitely nailed down that it is related to Print commands (regardless if using the SSRS Standard form or a custom report style).
We have reported this to Support and were told that this issue is fixed in a newer version but we aren’t satisfied with that response.
I will watch this case closely to see if you find something that may be helpful to us.

We have this all the time, its extremely annoying. We get it in the shipping module too. We also have turned off all the BPMs and still. The worst part of it is, if you made multiple changes it removes all of them when you hit refresh and you may not notice that. It adds a level of errors into everything. Shame there is no fix for something so serious.

@AWCScott @jackie
Are you guys on the cloud or on-premise?

I’m hosted, single site

Scott Thompson
IT Manager/Webmaster

Advanced Wireless Communications

Subbing to this thread; we have the same issue currently and we lose a lot of fresh data from customer entry when this pops up. The go-to has been to refresh consistently after performing any task that may have updated the record.

Be careful with the shipping and receiveing tables. Some of them are actually modified by the invoicing processes. I noticed this when I created a BPM on the receipt entry and it was triggering when our AP person was processing payments. The AR could be doing something with the custship stuff as well.

We see this often too, it does get annoying. Our users are used to hitting refresh before they enter and save the Order/Shipment/etc before moving to the next tab and repeat the Refresh/Enter/Save workflow.

This usually happens because there are different bpms trying to update or use the same business object at the same time, what you could do is check which bpms are being executed when you get that error, sometimes the indexing in the bpms can be part of the problem. a lttle loop in a bpm’s code can be causing this issue as well, I hope this help.

1 Like

Still does it even will all BPM’s disabled

Scott Thompson

1 Like

I see… it might be a UI problem… do you have some code in that screen that is updating some value??? this can be happening if you have code like oTrans.Update(); or if you are updating a dataView… if so… you should always use this line of code "oTrans.Refresh();… it usually throws that error when you are updating tuff and not refreshing the dataView on the Post Processing method

I do not have any special code or BPMs.

No customer code on the Ship screen at all. It happens all the time if you switch tabs without saving I think

Scott Thompson
IT Manager/Webmaster

Advanced Wireless Communications

Ok, so if you open this screen in base mode and with the BPMs disabled, it is still throwing the same error??

it doesn’t happen all the time. But frequent enough to where it is annoying to the user.